AnsweredAssumed Answered

r7 370 4k displayport link error

Question asked by harmen on Dec 6, 2016
Latest reply on Dec 8, 2016 by amdmatt

Hi,

 

I just got my new LG 27UD58 4k screen from lg wich supports displayport 1.2 and 60 hz@ 4k.

 

My videocard, an MSI R7 370 2GD5T OC gives Displayport Link errors and I don't get an image at all. Windows advises to use the monitor at 800x600 pixels. I also get the error message "Default Radeon WattMan settings have been restored due to an unexpected system failure".

 

The card is capable of showing 4k @ 60 hz over displayport (I don't game a lot).

 

I tried:

The newest hotfix driver, AMD driver cleaner, and the 16.9.2 driver.

I used the displayport cable that came with the new monitor.

With the OSD settings  of the screen I set it on displayport 1.2

I installed the display driver that came with the screen

I tried a Displayport -> HDMI cable I had laying around which only supported full hd.


Any tips? I am running the screen over HDMI now, my card only supports 30 hz (or even 24 hz, don't know).

Outcomes