AnsweredAssumed Answered

RX 480 Continually Crashing - "Radeon Settings: Host Application has stopped working"

Question asked by ryanadams on Dec 5, 2016
Latest reply on Dec 5, 2016 by rahod

So about five days ago I purchased the RX 480 8GB. At first I used DDU to remove all traces of the previous Nvidia driver so I could do a clean install of AMD drivers.

 

Like anyone else when they get a new GPU they go into the settings and have a look around - Radeon Settings crashed the very first time I opened it. I just rebooted and fired up a game. No problems.

 

Then it wasn't long before Radeon settings crashed again. Almost everytime it happens when I go to Gaming>Global Settings. Although it does just do it on its own sometimes.

 

I used AMD Clean Uninstall Utility and then used the Automatically Detect and Install your Driver utility. It downloaded Crimson Edition 16.9.2

Still crashes.

 

Decided screw it - fresh install of windows. I didn't have much to reinstall anyway. Installed the AMD Drivers. Still same issues. As for the latest "Hotfix" I tried to install the Crimson Edition 16.11.5 Hotfix but that crashed as soon as the installer opened - screen went black and my computer became totally unresponsive and I had to do a hard reset.

 

Thinking it might be a faulty card, I ran Unigine Heaven and Valley and also some 3DMark benchmark tests while I closely monitored the temps etc. No issues whatsoever. Runs like a charm.

 

Open up Radeon settings though, it crashes.

 

System specs:

 

Radeon Software Version - 16.9.2

Radeon Software Edition - Crimson

Graphics Chipset - Radeon (TM) RX 480 Graphics

Memory Size - 8192 MB

Memory Type - GDDR5

Core Clock - 1288 MHz

Windows Version - Windows 10 (64 bit) - All latest updates installed.

System Memory - 16 GB

CPU Type - Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz

 

Just before writing this post, it crashed again so here is the event log:

 

From the "General Tab"

Faulting application name: RadeonSettings.exe, version: 10.1.1.1648, time stamp: 0x57dc524e

Faulting module name: Qt5Gui.dll, version: 5.5.0.0, time stamp: 0x558c6cb7

Exception code: 0xc0000005

Fault offset: 0x0000000000017390

Faulting process id: 0x103c

Faulting application start time: 0x01d24ef867152fe6

Faulting application path: C:\Program Files\AMD\CNext\CNext\RadeonSettings.exe

Faulting module path: C:\Program Files\AMD\CNext\CNext\Qt5Gui.dll

Report Id: 21ff24da-6703-495a-8e98-a2f54e2454d0

Faulting package full name:

 

From the "Details Tab"

 

-System

 

-Provider
[ Name] Application Error

 

-EventID1000

 

[ Qualifiers] 0
Level2
Task100
Keywords0x80000000000000
-TimeCreated

 

[ SystemTime] 2016-12-05T13:18:06.205343700Z
EventRecordID4140
ChannelApplication
ComputerDESKTOP-
Security
-EventData

 

RadeonSettings.exe
10.1.1.1648
57dc524e
Qt5Gui.dll
5.5.0.0
558c6cb7
c0000005
0000000000017390
103c
01d24ef867152fe6
C:\Program Files\AMD\CNext\CNext\RadeonSettings.exe
C:\Program Files\AMD\CNext\CNext\Qt5Gui.dll
21ff24da-6703-495a-8e98-a2f54e2454d0

_______________________________________________________________________________________________________________

 

Does anybody have any idea what could be causing this or how I can fix it? It is driving me nuts here.

Before switching to this RX480 I was using a GTX 1060 and never once had a problem with it.

Outcomes