1 Reply Latest reply on Mar 29, 2017 2:33 AM by ssh9105

    FirePro W9100 Ubuntu 16.04 Performance Issue

    dalcacer

      Hello community,

      hello AMD,

       

      after a long time waiting and the interim deployment of a experimental driver,

      I’ve just installed the most recent, stable AMD pro driver for Ubuntu 16.04.

       

      My setup is a  headless workstation with a Radeon FirePro W9100 32GB which should be used for image processing (via opencl).

       

      I’m running

      • Ubuntu 16.04
      • Kernel 4.4.0-51-generic

      and I’ve installed

      • amdgpu-pro-16.40-348864
      • AMD-APP-SDK-v3.0.130.136-GA-linux64

       

      The driver seemed to be installed correctly:

       

      lshw -C display

        *-display             

             description: VGA compatible controller

             product: Hawaii XT GL [FirePro W9100]

             vendor: Advanced Micro Devices, Inc. [AMD/ATI]

             [….]

             configuration: driver=amdgpu latency=0

             […]

       

      lspci -nnk | grep -i vga -A3 | grep 'in use'

        Kernel driver in use: amdgpu

       

      However a quick test via pyopencl resulted in a benchmark which performed worse than before (with the experimental driver).

       

      It seems like only 16 GB of RAM and only 14 compute units out of 44 were detected:

      Device name: Hawaii

      Device type: GPU

      Device memory: 16192 MB

      Device max clock speed: 555 MHz

      Device compute units: 14

       

      Running /opt/amdgpu-pro/bin/clinfo produced a rather confusing output (find attached), which leads to the assumption, that

      something related to the driver might be broken.

       

      Does anyone have a similar experience (or even better a solution) with the FirePro W9100 running Ubuntu 16.04?

       

      Kind regards,

      Dorian

        • Re: FirePro W9100 Ubuntu 16.04 Performance Issue
          ssh9105

          Hi Dorian,

           

          I bought AMD Radeon FirePro W9100 32GB recently in order to reduce calculation time for OpenACC code which uses a lot of double type variables.(Before, I used NVIDIA GeForce)

           

          I installed

           

          I don't know about OpenCL, but when I ran clinfo in /opt/amdgpu-pro/bin directory, Board name appeared correctly and Max compute units is displayed as 44.(Please see the attached file. I did not include CPU part to reduce the size of the file)

           

          So, maybe installing amdgpu-pro-16.60-379184 might solve your problem, though I cannot guarantee that W9100 works with OpenCL program in Ubuntu 16.04.

           

          For me, when I compiled my OpenACC code with PGI Community Edition 16.10 for W9100, there was no error messages. However, when I ran that program, results are ridiculous in a sense that 1 + 1 gives NaN or 2.something e+305.

           

          My OpenACC code works perfectly fine when I used NVIDIA GeForce, so maybe there is some driver problem on AMD W9100 for Ubuntu 16.04. When I asked this problem to PGI Forum, someone told me that my OpenACC test code worked fine for Radeon 7660(PGI Userforums).

           

          I heard that Ubuntu 16.04 is not friendly with AMD drivers(especially fglrx), and I cannot monitor GPU usage via "amdconfig --odgc" and "amdconfig --odgt"(Monitoring GPU utilization). When I type that in my terminal,  it says that "amdconfig: command not found" even though "lshw -C display" and

          "lspci -nnk | grep -i vga -A3 | grep 'in use'" gives same results as yours.

           

          Best regards,

          Shin