0 Replies Latest reply on Dec 1, 2016 2:01 AM by hect0r

    Error : Cannot install/generate driver for Radeon 390 - Ubuntu Mate

    hect0r

      Ok So I installed a fresh copy of Ubuntu Mate 16.04, I have tryed both "amd-gpu-pro-16.40" and "fglrx-15.302" but neither seem to work.

       

      Firstly "amd-gpu-pro-16.40", I have install that via running ./amdgpu-pro-install it uninstalls and installs fine, no errors but I cannot get my gpu to show in OpenCL Platforms, just my amd cpu, so I uninstall that via runing ...pro-install etc, removes it including a autoremove from apt.

       

      Then with "fglrz-15.302" I have tryed install via Pregenerated Lib files and I get this error in the log file :

       

      [code]

      NOTE: If your system has logged the missing packages required for installation,

      NOTE: If your system has logged the missing packages required for installation, install them in the order as per the log file to resolve package-dependency issues.

      Supported adapter detected.

      Detected a previous installation, /usr/share/ati/amd-uninstall.sh

      Installation with force option.

      Check if system has the tools required for installation.

      fglrx installation is being forced. Installation will proceed without the required tools on the system.

      Uninstalling any previously installed drivers.

      Forcing uninstall of AMD  Proprietary Driver.

      No integrity verification is done.

      restore of system environment completed

      Errors during DKMS module removal

      Uninstall fglrx driver complete.

      For detailed log of uninstall, please see /etc/ati/fglrx-uninstall.log

      System must be rebooted to avoid system instability and potential data loss.

      /usr/share/ati/amd-uninstall.sh completed with 0

       

      Creating symlink /var/lib/dkms/fglrx/15.302/source ->

                       /usr/src/fglrx-15.302

       

      DKMS: add completed.

       

      Kernel preparation unnecessary for this kernel.  Skipping...

       

      Building module:

      cleaning build area....

      cd /var/lib/dkms/fglrx/15.302/build; sh make.sh --nohints --uname_r=4.4.0-51-generic --norootcheck....(bad exit status: 1)

      [Error] Kernel Module : Failed to build fglrx-15.302 with DKMS

      [Error] Kernel Module : Removing fglrx-15.302 from DKMS

       

      ------------------------------

      Deleting module version: 15.302

      completely from the DKMS tree.

      ------------------------------

      Done.

      [Reboot] Kernel Module : update-initramfs

      ~

      [/code]

      I have installed the missing packages previously, nothing is left to install and a quick look in lspci | grep vga shows the following :

       

      [code]

      hect0r@UNKNOWN:~/Desktop/fglrx-15.302$ lspci || grep vga

      00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex

      00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port

      00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)

      00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)

      00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)

      00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)

      00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)

      00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 14)

      00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)

      00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)

      00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)

      00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0)

      00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 2)

      00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0

      00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1

      00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2

      00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3

      00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4

      00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5

      01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290] (rev 80)

      01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii HDMI Audio

      04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)

       

      [/code]

       

      I dont know why it isnt working, any help would be greatly appreciated, also for the OpenCL program im using to display platforms/devices is vanitygen, Im using AMD APP SDK 2.9 and 3.0, I can compile vanitygen on both versions of them but they dont output the gpu only cpu