1 Reply Latest reply on Nov 27, 2016 8:20 AM by conflicker

    AMD A4 6210 never reaches advertised speed

    conflicker

      I just bought a laptop with A4 6210 Quad Core 1.8 Ghz (no turbo) 6 GB RAM and 500 GB HDD 5400 RPM w/ Windows 10

       

      But I noticed in task manager and using AIDA + benchmarks, the CPU is always working at 1.3 Ghz on windows (even with 100% CPU usage), and AIDA says it does reach 1.65 Ghz for a few miliseconds but most of the time it is working at 1.5 or 1.3 Ghz even when running prime95. I tried switching all power saving features in windows to Maximum Performance but It did nothing, the CPU does not even get hotter than 50º.

      I did a clean install of windows 10 and only installed the VGA driver, but still no success. The GPU never reaches the 600 Mhz advertised speed either, but I dont even care about that,

       

      It is still quite slow for multitasking, Firefox with 8 opened tabs and Eclipse, it takes like 3-5 seconds to switch between windows, even with low memory usage. Any slightly heavy program always takes 5-10 seconds to even open. My 10 year old Core 2 Duo desktop with 4 GB RAM is a lot faster than this laptop.

       

      Is this a normal behavior for these CPU´s or is there something faulty in it? Im thinking of installing an SSD because it also takes a long time to boot but with such slow CPU not sure if it will make a difference.

        • Re: AMD A4 6210 never reaches advertised speed
          conflicker

          Well nevermind, I updated the BIOS and now all programs are reporting the full 1.8 Ghz (altough it still drops to 1.3 Ghz for a few milliseconds even when stress testing with prime95 on all cores, but runs @1.8 Ghz almost always, same with the GPU runs at max mhz with short time drops ) . it also solved other issues with touchpad and false battery levels. Benchmarks are giving slightly higher values now but  still has very low performance even for basic tasks