1 Reply Latest reply on Nov 26, 2016 6:13 AM by redfury

    R9 XFX 380 4GB Battlefield 1 DirectX Crash

    connornee

      I have an issue when playing battlefield 1. Sometimes this error occurs once and then goes away but now it has started to happen frequently now and is starting to annoy me. Here is a screenshot of the error message after the windows sound plays: https://gyazo.com/936622ee1825201f0b0e0c04bd105f87

       

      This doe not happen to me in any other game, I have the latest driver installed for my GPU.

        • Re: R9 XFX 380 4GB Battlefield 1 DirectX Crash
          redfury

          INFORMATION REQUIRED WHEN POSTING A QUESTION

          Disable the origin overlay

          PC players have the unfortunate requirement to install Origin to download and play EA games. Now is not the time for a debate about how bad Origin is but let's understand how to disable the monster which is unnecessarily consuming resources on your PC.

          Steps:

           

          1. Start Origin
          2. Open Origin
          3. Click Settings from the main menu (top of window)
          4. Click "Origin in Game"
          5. Untick the box labelled Enable Origin in Game

           

          Turn off DX12 in the game menu

          The developers have added the ability to disable DX12 in Battlefield 1. Follow the steps below to switch it off:

           

          Steps:

           

          1. Open main menu (press ESC)
          2. Click Settings
          3. Choose Video Settings
          4. Click Advanced
          5. Untick DirectX12

          Check page file is set to auto

           

           

          Letting your PC manage its own page file is a wise choice (unless you really know what you're doing). This file is designed to allow RAM to overflow to physical disk in times of distress. Setting a stupidly low or even high file size will have negative effects.

           

          Check that your page file is set to automatic through the Windows control panel:

           

          Steps:

           

          1. Open System properties
          2. Advanced tab
          3. Performance
          4. Settings -> Advanced tab
          5. Virtual Memory
          6. Tick the Automatic page file managing

           

          Check your GPU temp.

          Try last WHQL driver.