6 Replies Latest reply on Nov 28, 2016 8:23 AM by len603203

    cannot install latest drivers

    windowsliveevan@yahoo.com

      Cannot install latest drivers. I don't see a way here to post the fail log.

        • Re: cannot install latest drivers
          len603203

               I'm having an issue installing (upgrading or installing) Crimson 16.11.4.  It gives an error that it can't extract a file.  In 7 attempts, it was the same file 6 (5 posted)  times at different percentages (extracting failure), and another file as well so it doesn't seem to be a specific file problem.  I thought it was my firewall (Avast), and tried turning it off, then uninstalling it altogether with no luck.  I'm trying to install as admin (I've done this stuff for several decades and know my way around software / hardware).  I have not uninstalled / cleaned / installed, because I don't want to waste my time (I'd just wait for the next version because this one (16.11.3) is working fine).  I have copied text from the failed installs in 5 text files (below).

          AMD 1.PNGAMD 2.PNGAMD 3.PNGAMD 4.PNGAMD 5.PNG

           

           

          RX-470 (ASUS Strix ROG 4Gb)

          Desktop

          Windows 10 Pro

          Crimson 16.11.3 (current)

          Sanyo 34" TV

          Phillips 55" Ultra4k

          AsRock Killer Fatal1ty 990FX

          AMD FX-8350

          CoolerMaster v650

          32 Gb Memory (Mushkin Radioactive 1600 MHz running at 1300 / 7-7-7-19)

            • Re: cannot install latest drivers
              redfury

              Delete C:\AMD folder and try again - manually download and install this driver

                • Re: cannot install latest drivers
                  len603203

                  Sorry, been there, done that several times.  I know to get rid of the AMD folder.. I knew the error was during extraction.  The link took me to the same driver I tried (the link was purple confirming it's the exact same one (16.11.4)).  Thanks anyways.

                   

                  I ended up finding the cause of this, and it had nothing to do with the driver.  I have an ASRock board, and there is a program called "XFast RAM" (which is a RAMdrive program) that puts temp directories, swap files and page files into a virtual drive residing in memory.  I forgot it was even running.  I opened it this morning and noticed it was set at 1Gb max.  Before changing anything, I ran the Crimson install again and watched the drive fill to capacity before the same error as before came up when it was full.  I changed the size to 2.5 Gb, and after using 1.9 Gb of the drive, it successfully installed.

                   

                  My thinking is this, if anyone has a problem like this (with failed extraction), first check pagefile (or if you have this RAMdrive thing installed).  The extraction is bigger than I expected at around 2 Gb, so it needs plenty of room for it.  Hope that helps.  I haven't run the driver long, but it seems just fine.  Cheers.

                • Re: cannot install latest drivers
                  qwixt

                  Try using something like 7zip to extract files instead of the self-extractor .exe

                    • Re: cannot install latest drivers
                      len603203

                      That's a good idea providing 7zip didn't use the same TEMP directory as the installer did, but I found my problem.  I posted above.  Someone with a cluttered, nearly full system drive could run into something like this, or maybe someone who messed with their pagefile, but in my case it was ASRock software doing this.  Thanks.