4 Replies Latest reply on Dec 3, 2016 1:57 PM by kingfish

    Unable to install new AMD drivers and unresponsive Radeon Settings after System Recovery

    chilly

      Dear Support Team,

       

      I have quite some problems upgrading from an old Radeon Software Version (15.11) to the most up to date one (Crimson Edition 16.11.4 Hotfix).

      I will pretty much list up everything I did so far. Here are a few relevant Informations to my system first.

       

      GPU: Radeon R9 290X

      CPU: Intel Core i7-4770K @ 3.50 GHz

      OS: Windows 7 Professional, 64-bit

       

      1. First I made sure Windows and .Net Framework stuff is updated (Even optional Updates).

      2. Then I followed this tutorial here: Clean Install AMD Graphics Drivers since it would not allow me to upgrade it on its own.

      3. I went to Download Drivers and smacked these informations in: https://i.gyazo.com/5bc248a45a1edd54ab362cbd976fbc70.png

      4. Downloaded the Crimson Edition 16.11.4 Hotfix with release date: 11/17/2016 and 292 MB File Size.

      5. Went uninstall "AMD Install Manager" in Control Panel, it uninstalled stuff and made me reboot.

      6. I downloaded Display Driver Uninstaller (Ver.17.0.3.0) earlier -> Reboot into Safe-Mode, executed "Clean and restart" with DDU.

       

      Up to this point everything seems fine, but then problems start to occure when I try to install the Crimson Edition 16.11.4 Hotfix.

       

      7. Back to my desktop I try to run the 292 MB exe with the drivers, it unpacks files into C:/AMD and runs the setup.

      8. Now here is the part where it "should" create a bunch of files, but it only creates these files: https://i.gyazo.com/4396dda629d3de736404126f1043f75e.png

      9. Afer the installation, I need to reboot and my graphics card did not even take in the drivers, prolly because the whole installation is so incomplete.

      10. I guide my GPU manually towards the drivers in "C:/AMD/Non-WHQL..(etc) Crimson-16.11.4-Nov15/packages/drivers", works like a charm.

       

      However I don't have the rest. No radeon settings or whatever. It should roughly look like: https://i.gyazo.com/eff6a8c2cad82f572b4d694cc56326ac.png

      this during the installation of new Drivers, but instead of that it just shows me "AMD Installationmanager", "HDMI Audio Drivers" and these unticked optional profiles

      when I want to install the new drivers.

       

      Things I also did before anyone is going to ask:

      - Making sure Anti-virus/ad blockers/anti-malware/ anti-anything are disabled during the driver install

      - In another attempt to install the drivers, I tried out AMDCleanupUtility.exe before installing everything in addition, same results.

      - I will repeat it once more to avoid confusion: Windows and .Net Framework stuff is updated.

       

       

      And here is the bonus part: After simply being unable to install the whole thing correctly, I kinda gave up and tried a System Recovery to go

      2 days back in time and reset my System to my old Radeon drivers (Version 15.11). Now I do have everything back and there even is this

      Radeon Setting icon popping up as usual but then I realized.. It does not even respond anymore. I can click it, restart it, but nothing

      pops up and it is clearly activated when I look at the task Manager. So I am back to Version 15.11 but have no control over

      anything at the moment.

       

      I am quite puzzled and I simply don't know what to do anymore to fix this.

      I appreciate any help and hope there is a solution to my problem

       

      Best regards

      A troubled customer