7 Replies Latest reply on Nov 19, 2016 6:52 AM by redfury

    This app can't run on your PC

    mahmoud4228

      Hello, my AMD Crimson 16.11.3 just told me that there's a new update "16.11.4", so I decide to download it. When it finishes downloading, the set-up won't start. So I navigate to the the download location and try to click on the set-up, I get "This app can't run on your PC".

      This is not the first time it happens, but the last time it worked on its own, just like that. Dunno how it worked, but it just worked. But it's back again, so can I get any help?

       

      Also, I tried to download Catalyst driver to test it. But when I try to install the 64bit set-up, I get "This app can't run on your PC". So I try to download the 32 bit set-up. But it doesn't finishing installing and tells me that the set-up is not compitable with my OS since mine is 64 and the set-up's is 32, so it exits.

       

      Please, can I get any explanation why this happens?

      I want to install the Catalyst and the Crimson updates but these "This app can't run on your PC" errors appear out of nowhere, even if I download the right version of the set-up; which is the 64 bit.

       

      Thanks in advance.