1 Reply Latest reply on Dec 3, 2016 12:45 AM by feliperockz

    AMD Red Dragon RX 470 Driver crashing

    feliperockz

      Hi guys and and since now I'm apologizing for making another topic of this issue, but, lets go...

      I bought a new video card of AMD last month to retire my old partner GTX 650, I decide to move do AMD because the lower price than their competitors and also because the newer  line up that has comming, I was saving money since July and only last month I could buy it.

       

       

      My video card has arrived and I was excited to play, but I have a VGA monitor, so, I bought and HDMI to VGA adaptor and works fine, I tested some games (testing means, I play for  something arround 5 to 10 minutes each) some games like PES 2016 worked fine, but while I was playing Blade and Soul online I was experiencing some crashes, the screen went black and apearing the following messege on right bottom of screen: "Display driver stopped responding and has recovered".

       

      Since that moment I was thinking that could be a bug of Blade and Soul online, but, in the following week it released Dragon Ball Xenoverse 2, I downloaded and play it, on the begining was fine, but on the fighting scenes in something about 10 minutes starts to do the same crash as Blade and soul, so I tried to play some other games, most of then was running fine but GTA V and Bulletstorm presented the same crash, I tried every tutorial on Youtube, Google and even here in Support Forum and none of them solve my problem, here a List of everything that I tried on chronologial order:

       

      -Clean the video card and the RAM memory contacts
      -Run memtest to searching for possible RAM error (all tests were fine for 12 hours)
      -Tried the Tdr on register changing delay value to 8 (not work)
      -Instaling back to Windows 7
      -Tried the Tdr on register changing delay value to 8 on Windows 7 (both 32 and 64 bit comands)
      -Downgrade drivers from the last 3 ones
      -Downlgrade to the last WHQL Driver
      -Upgrade Bios
      -Lowering the clock speed
      -Change to a new pair of 4 gb on dual channel ram (corsair ones)
      -Change the Power Settings on Windows

      -Test the Power Supply and CPU
      -Test in another PC (with the same mobo model and the last drivers)

      -Tried to install the beta driver on CD
      -Overclock the cooler with afterburner (even with 30 to 40C during gameplay it crashed to...)

       

      My pc configuration is:

       

      -Corsair Power Supply of CX - 500w
      -Mobo Asus m5a78l-m lx v2 with the last BIOS Upgrade avaliable
      -AMD 6300 of 3.5 GHz and all the cores unlocked with a TX3 cooler
      -8gb of RAM (2x4 Kingstone HyperX on dual channel)
      -One HD seagate os 1TB and another samsung with 500gb
      -Rx 470 of 4gb
      -A soundblaster offboard video card


      The configuratoin of the other PC that was tested:

       

      -A Termaltake of 700w
      -Mobo the same of mine
      -A AMD cpu 4x (don't know the model)
      -8gb of ram

      -500 gb of hd

      -A native HDMI and DVI-D monitor

       

      Games that I tested and crashed:

       

      -Blade and Soul online
      -GTA V
      -Dragon Ball Xenoverse 1 and 2 (both have the same problem, something that didn't happen on mt GTX 650)
      -Bulletstorm
      -Battlefield 3 and 4

      -Sonic Generations

       

      Games that I tested and works fine:


      -Metal Gear Rising
      -Resident Evil 0 and Remake
      -PES 2016
      -Tabletop Simulator

      -Dead or Alive 5

      -WWE 2k16

       

      I hope there is a solution because the RMA in my country is very ****, thanks for your helping since now, if you need something else, please ask it.