2 Replies Latest reply on Nov 10, 2016 7:26 AM by abi

    RX 480 and BIOS/UEFI

    p.s.y.c.h.o

      First of all, English is not my mother tongue, so be pacient.

       

      I bought a Sapphire RX480 4GB Nitro+ last month, installed it after doing all the procedure of removing the drivers first and so on. Things were going fine, really great card, nice FPS and such, I had no complaints, then last week I was playing World of Tanks when suddenly the screen blacks out, comes back again with the message "The AMD video driver stopped responding and was recovered.". Tried to open the game again, same thing, tried to open BF4, same thing happened. So I decided to wipe off the drivers again and do a reinstall, no success.

       

      I tried every single kind of solution I could find (some I already knew, I'm not new to PC), none worked, so I messaged the store from where I bought the card, after some redundant e-mail exchange they finally allowed me to RMA the RX480, did that yesterday, in the meantime I was still looking for a possible answer to this issue, when I saw some reports about the BIOS/UEFI thing.

       

      Funny thing is that many of these reports show that the PC didn't boot at all, which wasn't my case, the problem only happened after I installed the drivers and tried to do something that would use a little more of the graphics card. If I didn't install the drivers, the card would not give any problems, but you can't use it's full potential this way.

       

      So, here is my rig:

       

      FX-6300

      Gigabyte GA-78LMT-USB3 (rev 5.0)

      XFX R7 260X

      3x Sata HDD

      3x 4GB DDR3 1333MHz Corsair Value

      Cooler Master GX550

       

      Which brands manufacture their cards with BIOS+UEFI, only BIOS, only UEFI, and UEFI/Legacy mode support? I was looking at the XFX ones, they seem to be really nice. Maybe I can get in some sort of agreement with the store, so I can have another VGA from other brand.