6 Replies Latest reply on Nov 9, 2016 3:58 AM by elpusher

    [W10] Grim Dawn performance - RX480


      Describe your system:

      • AMD Graphics Card: RX 480 Nitro 4GB (Sapphire)
      • Desktop or laptop system: Desktop
      • Operating System: Windows 10 64 bit [14393.351]
      • Driver version installed: Radeon Software Crimson Edition 16.11.2 [now 16.6 from win updt.]
      • Display Devices: BenQ 1440x900x75Hz [DVI]
      • motherboard: Gigabyte X99 Gaming V
      • CPU / APU: Intel i7 5960-x [8 cores - hyperthreading disabled]
      • Power Supply Unit Make, Model & Wattage: Corsair 850W
      • R.A.M: 8GB DDR4


      Hello people. I know this aging game engine is suffering from lack of optimizations but I have done everything I can think of and it still not running that well. In fact, any other game runs okay except this one, which was running a lot smoother with my previous nVidia GTX 970. Now, in Grim Dawn the game almost stalls when there is a lot of movement in screen. Everything at low settings except for textures and rendering (high). Anything else is disabled; shadows, AA, AF... To add insult to injury I had to downgrade Crimson driver version from latest one (2016 november) to the one offered by Windows Update. Yes, it's running noticeably better. Any ideas would be greatly appreciated.

        • Re: [W10] Grim Dawn performance - RX480

          Your machine should be doing very well at that resolution for this game.


          "Driver version installed: Radeon Software Crimson Edition 16.11.2 [now 16.6 from win updt.]"


          I suspect that the "now 16.6" might be the root cause of your issue. I suggest turning off automatic driver updates in win 10, which means you will manually have to keep it updated in the future. I think 16.6 might be the very first driver for that card.


          1. Turn off win 10 auto updates

          2. uninstall current drivers

          3. download and install the latest amd drivers, 16.11.2 as of today.


          Stop automatic driver updates on Windows 10 | Windows 10 content from SuperSite for Windows

            • Re: [W10] Grim Dawn performance - RX480

              No. You misunderstood me. In fact, Windows Update OLDER driver is performing better for me.

                • Re: [W10] Grim Dawn performance - RX480

                  Sorry about that. This is puzzling. I have 5820k and Fury, and the game plays well for me. I do have hyperthreading on, and I have 32 gb memory. I would think 8 gb would be sufficient for this game.


                  I would suggest turning off background processes, even antivirus to see if there is some sort of conflict, as you try to troubleshoot this. Sometimes OC tools like Afterburner can cause issues with games too.

                    • Re: [W10] Grim Dawn performance - RX480

                      Thanks for the tips. So far, I am not running any relevant third party programs/background processes. I have even set an exception for Windows Defender to ignore the whole STEAM folder. I am not overclocking either but I am using RadeonPro to force VSYNC, because the in-game built-in option isn't working well for me.

                      I could try disabling real time scanning inside Windows Defender for a while and try that. I could even try a different AV program. This is puzzling because any other game I play runs pretty fine.

                        • Re: [W10] Grim Dawn performance - RX480

                          Another thing to try is to set affinity for the grim dawn process and limit it to something like 2-4 CPUs just in case there is something strange going on.


                          In win 10 task manager, there is a good set of monitor tools that you can run, then when you see it chugging along, switch back to desktop, and check if your computer is having I/O issues.


                          Do you have it set to fullscreen, and not borderless windowed?

                          1 of 1 people found this helpful
                  • Re: [W10] Grim Dawn performance - RX480

                    Yes GD seems to be quite picky about cpu affinity and it isn't specially hyperthreading friendly either.


                    I am playing fullscreen.