0 Replies Latest reply on Nov 5, 2016 11:59 AM by jackrabbit

    Overclocking error RX 480 in Linux

    jackrabbit

      I have a MSI Gaming X 8GB RX 480 videocard and want to overclock the memory using the pp_mclk_od method, eg:

       

      echo 10 > /sys/class/drm/card0/device/pp_mclk_od

       

      However I see no performance boost and I get these messages in syslog/dmesg:

       

      kernel: [   94.113699]  failed to send message 18b ret is 0

      kernel: [   94.113704] VDDCI is larger than max VDDCI in VDDCI Voltage Table!

      kernel: [   94.123989]  failed to send message 18a ret is 255

      kernel: [   94.124002]  failed to send pre message 145 ret is 255

       

      I also tried undervolting the GPU system clock first (which works) but the errors stay.

       

      echo manual > /sys/class/drm/card0/device/power_dpm_force_performance_level

      echo 4 > /sys/class/drm/card0/device/pp_dpm_sclk

       

      Also funny thing is that DPM switches back to automatic after using the pp_mclk_od option.

       

      My system:

      -Ubuntu 16.04

      -Kernel 4.8 / 4.9 rc2 (tried both)

      -AMDGPU Pro 16.40 driver

       

      Does anybody have an idea what the problem is?

       

      I have read that editing the videocard BIOS might resolve the problem but really I do not want to fiddle with my VGA BIOS and possibly void my guarantee on the card...