1 Reply Latest reply on Apr 8, 2017 5:06 AM by tux4lyfe

    Can't select 4k//60 Ubuntu rx 460 driver amdgpu-pro-16.40-348864

    ghent360

      Hi,

       

      Running ubuntu 16.04.1, 64 bit kernel version 4.4.0-45. My display is Vizio D40u tv connected via HDMI 2.0 port. I was able to select 2160p mode, but it goes only to 30Hz.

       

      This is the output from xrandr:

      Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384

      DisplayPort-0 disconnected (normal left inverted right x axis y axis)

      HDMI-A-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 878mm x 485mm

         3840x2160     30.00*+  24.00    29.97    23.98 

         4096x2160     24.00    23.98 

         1920x1200     30.00 

         1920x1080    120.04   120.00   119.88    60.00    59.94    24.00    23.98 

         1600x1200     30.00 

         1680x1050     30.00 

         1280x1024     30.00 

         1440x900      30.00 

         1280x800      30.00 

         1280x720      60.00    59.94 

         1024x768      30.00 

         800x600       30.00 

         720x480       60.00    59.94 

         640x480       60.00    59.94 

      DVI-D-0 disconnected (normal left inverted right x axis y axis)

       

      However if I decode the EDID provided by the xrandr --prop it states that mode 97 is supported as well as mode 102. Both modes are 2160/60Hz.

      I'm attaching the output of xranrd --prop.

        • Re: Can't select 4k//60 Ubuntu rx 460 driver amdgpu-pro-16.40-348864
          tux4lyfe

          You can create new modes for xrandr to fun at a higher frequency. On linux (ubuntu 16.04), I could only get my rx480 to put out 50Hz at UHD stably. At 60Hz the screen flickers. On windows, however, the rx480 puts out 4k 60Hz 4:4:4 without an issue - so it must be an issue with the linux amdgpupro driver.

          Anyway, here's how I enabled 50Hz:

          xrandr --newmode "3840x2160_50" 445.008 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync && xrandr --addmode HDMI-A-0 3840x2160_50 && xrandr --output HDMI-A-0 --mode 3840x2160_50
          Remember to substitute HDMI-A-0 for your connected device.
          Also to note, this command isn't persistent, meaning you'll be at 30Hz again every time you reboot.