2 Replies Latest reply on Nov 4, 2016 10:33 PM by Earnhardt

    Crossfire experts: need help


      Hello, AMD community, I am new here. I would like to present you my recent problem and ask you help to resolve it.


      My setup is:

      AsRock Fatality killer 990FX

      Amd FX 8320 OC @4.0 GHz

      16 Gb RAM

      2xATI 5770 (Asus and Sapphire)

      PSU 650w


      Here is the situation: I recently bought for 20 euros the second 5770 to set up my first crossfire, yes we are really talking of a 6-7 years old GPU, yes I do play and have always played with a single 5770 especially because my resolution is 1336x768 so i don't need a powerful setup; if your answer is "blabla OLD, blabla BUY" stop reading here and switch thread please.


      What I did: after installing the second GPU, the drivers I had already installed instantly recognized and enabled CrossfireX mode, ok nice.

      I noticed the first problem, the GPU2 datas were 0 temp, 0 load, 0 gpu and memory freq; I installed the latest available drivers and after a few researches I found that the problem was UPLS, so I manually disabled it from regedit, well now the GPU turned on.


      I tried to start a couple of games to see if FPS changed, Battlefield 4 (fullscreen of course), nice it did but the problem is that I do less fps than before (?) seeing from Afterburner datas i notice that GPU1 is not working any more at 90+% but it maxes at 60/70% while GPU2 at 30/40% .

      Furmark benchmark test in widowed mode runs at 25 fps while the same test in fullscreen runs at 50 fps so maybe here crossfire is working as intended?

      War Thunder: less fps; PlanetSide2: less fps; Battlefield 3: less fps; The Crew: who knows, the game locks its fps at 60


      Ok, thanks for reading


      First question: WHY

      Second question: HOW DO I FIX

        • Re: Crossfire experts: need help

          1. ULPS puts the second GPU into 'sleep mode' during periods of 3D application inactivity. It saves power and the temperature and other values should read 0 until it wakes up. You do not need to disable it.

          2. What you have described sounds like a CPU bottleneck. Not much if any performance improvement and low GPU usage. At the resolution you are using, this is not a surprise. You can alleviate this bottleneck somewhat by doing any of the following.


          1. Using the fastest compatible system memory with your Motherboard (DDR3 2400MHZ?)

          2. Overclocking your CPU to allow the GPUs a little more headroom to stretch their legs.

          3. Use a higher resolution or image quality settings (Ultra preset?) to move the bottleneck from the CPU to the GPUs. You can use BF4's resolution scaling if your monitor is already running at the highest possible resolution.

          4. Sell both of your GPUs and buy an RX 460 or an RX 470. This will offer better value and performance than the current GPUs you have now. You will get better performance.

          • Re: Crossfire experts: need help

            And BF3 and 4 give the best scaling, almost 100% with my setup.