8 Replies Latest reply on Nov 7, 2016 12:56 AM by grizlodĀ®

    rx 480 low fps

    leonvalko

      Hi, i have a problem and im very worried about it . i buy a rx 480 red devil 8gb like 2 weeks ago and i test it in dark souls 3, gta 5 and skyrim special edition...

      and i have very low fps :

      skyrim SE : 30-40

      dark souls3: 50-60

      GTAV: 30-36

      i also do a heaven benchmark and i got 1330 score on it

      i dont really know whats the problem but everytime i see a benchmark or a test on ultra in youtube the guys have like  high fps in all the same games i play on my pc.

      can you help me? i need to know whats causing the low fps.

      my pc setup is :

      GPU - Radeon (TM) RX 480 Graphics - 8192 MB - GDDR5 - 1330 MHz

      Windows - Windows 10 (64 bit)

      RAM - 32 GB

      CPU - AMD FX(tm)-8120 Eight-Core Processor

      Mobo - gigabyte 990fxa-ud3

      please please help me

      I try a lot of things, like changing the gpu from slts/dcks, reinstaling drivers, reinstaling games, reinstaling windows, play with the configurations a lot!, disabling the energy and compatibility mode....

      nothing works for me.

      please please please help me i dont want this purchase be a loss of money i was to excitet for my red devil ... its so badas .

       

      (sorry for the bad english)

        • Re: rx 480 low fps
          sandrino

          You should really consider to upgrade that CPU as that is most likely what is causing your low fps especially on GTA V and skyrim as those are more heavy on the cpu and creates a bottleneck.

          1 of 1 people found this helpful
          • Re: rx 480 low fps
            goodplay

            Try lowering some game settings (the 480 is only a (higher end)mid range card).

            Also over riding Tess. to 32x in radeon global settings will improve min frame rate in many games.

            • Re: rx 480 low fps
              guily6669

              One of the problems there sadly is the fact that you went with AMD cpu instead of a Intel...

               

              Sadly theres lot of games that loses 20 FPS just by having a AMD CPU .

               

               

              But it might be other problem.

               

              If you dont have a SSD, run and buy one right away, modern PC's just can't stand HDD's anymore.

               

              I always bought the best HDDs out there and had big problems, PC slowdowns... After buying a SSD the PC is always super fast.

               

               

              When I made my PC I couldnt play almost any game, it was very slow and lagged, at the end I found out both my brand new WD Blacks weren't good and was causing all the lag.

               

              If you have or get a SSD, try installing specially GTA on the SSD and see if the problem still happens.

               

               

               

              About the power limit option, I have the option on mine. Make sure you have the latest AMD drivers, if not, use DDU app in safe mode and clean the AMD drivers and install the latest ones.

               

              If your AMD CARD manufacturer has a app to control it, download the latest version and check if the clocks are set correctly to the max claimed factory clocks.

               

              Also check if the manufacturer has a new Bios for your GPU to be flashed. My Asus Strix RX480 I have it for like 3 or 4 weeks and have updated bios twice, mine is at 1.02 at the moment.

               

               

              For last Overclock the CPU to a safe level and run a CPU benchmark and make sure it doesnt go over ~80Cº and that it is stable, this will instantaneously give you more FPS.

              • Re: rx 480 low fps
                grizlodĀ®

                The cause is almost certainly attributable to the relatively low frequency stock of your processor.

                Fortunately all FX are unlocked ...

                Enter the BIOS by pressing [Del] (or [F2]) at bootstrap, set in manual menu to enable independent control of frequency and voltage.

                Disable the turbo-core, the various 'spread spectrum', APM and energy savings, except Cool & Quiet.

                Raises the CPU frequency via multiplier @ 4200~4400 MHz, adjusting the vcore @ 1.350v ~ 1.400v.

                Raise the frequency of the CPU/NB (NB Core), bringing it @ 2400 MHz, vnb 1.2800v ~ 1.310v.

                Presses [F10] and restart. Do some stability test and if ok, try to play ...

                 

                 

                P.S. I hope you have a good power supply and a good heatsink ...