3 Replies Latest reply on Nov 6, 2016 12:52 PM by rjpaiz

    Blank screen problem on fresh install

    rjpaiz

      My system had been running stable for about two years on an Nvidia card. I updated to a Sapphire R9 380 card. No other hardware changes. Wiped and reinstalled the system fresh: Win 10 Pro 64-bit x64, all hardware and drivers fully updated and patched. Installed Crimson 16.10.2 from AMD's site. The system works fine as long as I boot and keep working. But... if I leave for an hour or so, then when I come back the screen goes black for 2-5 seconds (it varies), comes back for about a half-second, goes blank again for 2-5 seconds, comes back for a half-second again, and will either keep doing that or then stay blank. The system is responsive: I can type while the screen is blank and see what I typed when it briefly displays again; and blindly entering the keystrokes for a system restart works fine even when the screen is blank and staying that way.

       

      However, obviously I can't work this way! It happens when the system wakes up from sleep, or even if I tell it never to sleep, if I leave it alone for an hour or so it blanks when I come back. A restart fixes the problem temporarily, and as long as I continue a work session without interruption I can work for 3-4 hours after a fresh boot with no complications. But leave, or sleep, and the blanks return.

       

      I've made totally sure that the system is updated and patched. Searching the forum has yielded nothing: lots of people have crashes with a blank screen, but I can't find threads about a blank screen on a responsive system. Thanks in advance for any ideas!! I'll post hardware details below:

       

      Radeon Software Version - 16.10.3

      Radeon Software Edition - Crimson

      Graphics Chipset - AMD Radeon (TM) R9 380 Series

      Memory Size - 2048 MB

      Memory Type - GDDR5

      Core Clock - 980 MHz

      Windows Version - Windows 10 (64 bit)

      System Memory - 16 GB

      CPU Type - Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz

       

      Radeon Settings Version - 2016.1025.1747.30190

      Driver Packaging Version - 16.40.2911.1001-161025a-308178E

      Provider - Advanced Micro Devices, Inc.

      2D Driver Version - 8.1.1.1571

      Direct3D® Version - 9.14.10.01221

      OpenGL® Version - 6.14.10.13456

      OpenCL™ Version - 21.19.155.257

      AMD Mantle Version - 9.1.10.0163

      AMD Mantle API Version - 102400

      AMD Audio Driver Version - 10.0.1.0

      Vulkan™ Driver Version - 1.3.0

      Vulkan™ API Version - 1.0.26

       

      Graphics Card Manufacturer - Powered by AMD

      Graphics Chipset - AMD Radeon (TM) R9 380 Series

      Device ID - 6939

      Vendor ID - 1002

      SubSystem ID - E305

      SubSystem Vendor ID - 174B

      Revision ID - F1

      Bus Type - PCI Express 3.0

      Current Bus Settings - PCI Express 3.0 x16

      BIOS Version - 015.047.000.012

      BIOS Part Number - 113-C7660411-O05

      BIOS Date - 2015/07/16 02:04

      Memory Size - 2048 MB

      Memory Type - GDDR5

      Memory Clock - 1400 MHz

      Core Clock - 980 MHz

      Total Memory Bandwidth - 179 GByte/s

      2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000

        • Re: Blank screen problem on fresh install
          rjpaiz

          I've been working on this system today for four hours in the morning, then a two-hour interruption, then four hours again. As long as I reboot and stay active, it works fine. After the two-hour interruption, the blinking was back.

           

          I verified in the BIOS that the onboard graphics were fully disabled: they are.

          • Re: Blank screen problem on fresh install
            amdmatt

            Could be several things.

             

            1. Bad display cable. If connected via DP, use a DP certified cable. Accell DP cables are very good.

            2. Check Windows Device Manager > Monitor to ensure that the Monitor is not showing as disabled.

            3. Navigate to Radeon Settings > Displays > and make sure GPU scaling is off and Scaling Mode is set to Full Panel.

            4. Could be a local Windows OS issue. Have you tried reinstalling Windows?

            5. Could be a GPU specific issue, perhaps faulty.

              • Re: Blank screen problem on fresh install
                rjpaiz

                Thanks, Matt.

                 

                1. Had already verified cable. Was working well with prior GPU, also worked well on another system.

                2. Monitor was already properly detected, nothing showing as disabled or problematic.

                3. Scaling was set to "preserve aspect ratio," changed to "full panel".

                4. Had already reinstalled Windows, no joy.

                5. Hope not! May be a last resort. Also reaching out to Sapphire tech support, I can't live with a computer where everything must be saved and shut down if I'm going to step away for an hour.

                 

                Appreciate your help. Will see if #3 helps any and will report back.