1 Reply Latest reply on Oct 31, 2016 3:46 PM by gonzohop

    RX480 random black screen via Displayport to Ultrawide

    gonzohop

      Hi all

       

      At my wits end here. Here's my new build:

       

      XFX Radeon RX 480 Core Edition 8GB GDDR5 Graphics Card
      Intel i5 6400 Skylake 2.7GHz Quad Core 1151 Socket Processor
      Asus H110M-PLUS Motherboard Micro ATX
      Crucial CT2K8G4DFS8213 16 GB (8 GB x 2) DDR4 2133 MT/s DIMM 288-Pin Memory Kit
      Noctua NH-D15S CPU cooler
      SanDisk Ultra II SSD 240 GB Sata III 2.5-inch Internal SSD
      Seagate Expansion 2TB USB 3.0 Portable 2.5 inch External Hard Drive
      EVGA 430W PC Power Supply
      NZXT 2m LED Cable
      Windows 10 Pro 64-bit

       

      ... connected to an LG 34UC98 34-Inch UltraWide WQHD IPS Curved LED Monitor via Displayport.

       

      I've also got my MacBook Pro hooked up via the Thunderbolt port.

       

      Everything behaves itself until the GPU gets heavy load. When I'm playing WoW or The Secret World the screen will randomly go black, for maybe 2 seconds, before returning to normal. This can be at any time. Sometimes no problems for 20 minutes, sometimes it'll happen within minutes of playing. I can't define a pattern. I've tried a new DP cable. But nothing crashes - I can continue as normal, it's just the display going black and coming back on.

       

      I've tried everything I can find on the forums; rolling back the GPU drivers, playing around with Wattman and Afterburner settings, reinstalling drivers - everything I can find, but nothing works.

       

      The GPU isn't overheating - it never goes over 64 deg C. The CPU never exceeds 34.

       

      And what's even more curious is that it works with no problems at all if I connect the monitor via DVI to HDMI or HDMI to HDMI - the problem seems localised to the DP. But with the LG monitor Freesync only works via DP so I need that to be working. I've tried having Freesync enabled and disabled.

       

      I know the PSU is the lowest of the low power wise but I've calculated the draw is within limits and it all works fine on a connection other than DP.

       

      I've tried dialling down the graphics settings but that didn't work. I tried disconnecting the Thunderbolt cable and that didn't work. I've tried each of the 3 DisplayPorts - nope. I tried a different mains outlet for the monitor and that didn't work...

       

      ... but what DID work was changing the game resolution from the maximum monitor resolution of 3440 x 1440 to 2560 x 1080 - and then it works perfectly.

       

      But I don't understand why this is when it works fine at maximum resolution via HDMI.

      I've  blasted the card with an Xtreme burn-in with FurMark on full 3440 x 1440 res and it performed beautifully - not one black screen.

       

      One thing caught my eye in a WoW forum. One poster mentioned "DisplayPort still has some glitchy behaviour with certain monitors at certain refresh rates, causing a page buffer fault". This got me thinking that perhaps the DisplayPort isn't communicating properly between the PC and the monitor so, despite installing the driver off the LG CD-ROM, I downloaded the latest driver from the LG website. It said it installed and I tried playing again - no luck, same problem. Grrr. But I looked in to it further and opened the Device Manager and checked out Monitors. It was showing the Microsoft Generic PnP driver. Hmm, that's not right - could that be the problem?! So this time I installed the driver using the Device Manager rather than using the exe file and it installed fine. I thought it worked as it went around 30 minutes before the problem returned.

      I've tried a new card (thank you Amazon) but no, that didn't change anything.

       

      So it works on HMDI (therefore losing Freesync) and 2560 x 1080 on the the DisplayPort (which doesn't look so good on the Ultrawide), but not on max resolution on the DisplayPort.

      I'm really scratching my head here - any ideas?

      Many thanks.