AnsweredAssumed Answered

Radeon HD 7670 drivers not working on Windows XP PRO (32bits)

Question asked by longshotphil on Oct 27, 2016

Hi,

First thing first english is not my mother tongue so please be forgiving.

 

I installed a Radeon HD7670 in my computer last monday (24th october) and since I wasn't able to install the drivers for it.

Usally this is not a big thing but for some reason this one is a bummer. Despite some research on Internet and even emails

with an AMD technician I still can't figure this one out.

 

To start of here are some info took from a fresh DXdiag:

 

------------------

System Information

------------------

Time of this report: 10/27/2016, 17:30:01

       Machine name: VOHL022

   Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_qfe.130704-0421)

           Language: French (Regional Setting: French)

System Manufacturer: LENOVO

       System Model: 5474A71

               BIOS: LENOVO BIOS Rev: 1.0

          Processor: Intel(R) Core(TM) i5 CPU         750  @ 2.67GHz (4 CPUs)

             Memory: 3006MB RAM

          Page File: 1350MB used, 3542MB available

        Windows Dir: C:\WINDOWS

    DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

     DxDiag Version: 5.03.2600.5512 32bit Unicode

 

------------

DxDiag Notes

------------

  DirectX Files Tab: No problems found.

      Display Tab 1: The system is using the generic video driver.  Please install video driver provided by the hardware manufacturer. Direct3D functionality not available.  You should verify that the driver is a final version from the hardware manufacturer.

        Sound Tab 1: No problems found.

          Music Tab: No problems found.

          Input Tab: No problems found.

        Network Tab: No problems found.

 

--------------------

DirectX Debug Levels

--------------------

Direct3D:    0/4 (n/a)

DirectDraw:  0/4 (retail)

DirectInput: 0/5 (n/a)

DirectMusic: 0/5 (n/a)

DirectPlay:  0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow:  0/6 (retail)

 

---------------

Display Devices

---------------

        Card name:

     Manufacturer:

        Chip type:

         DAC type:

       Device Key: Enum\

   Display Memory: n/a

     Current Mode: 1280 x 1024 (16 bit) (1Hz)

          Monitor:

  Monitor Max Res:

      Driver Name: vga.dll

   Driver Version: 5.01.2600.0000 (French)

      DDI Version: unknown

Driver Attributes: Final Retail

Driver Date/Size: 4/14/2008 08:00:00, 9344 bytes

      WHQL Logo'd: Yes

  WHQL Date Stamp: n/a

              VDD: n/a

         Mini VDD: vga.sys

    Mini VDD Date: 4/14/2008 08:00:00, 20992 bytes

Device Identifier: {D7B70EE0-4340-11CF-B063-282AAEC2C835}

        Vendor ID: 0x0000

        Device ID: 0x0000

        SubSys ID: 0x00000000

      Revision ID: 0x0000

      Revision ID: 0x0000

      Video Accel:

Deinterlace Caps: n/a

         Registry: OK

     DDraw Status: Not Available

       D3D Status: Not Available

       AGP Status: Not Available

DDraw Test Result: Not run

D3D7 Test Result: Not run

D3D8 Test Result: Not run

D3D9 Test Result: Not run

 

So as you can see I'm still running Windows XP PRO (32bits) and upgrading is not an option. My screen is plug in the Radeon HD7670 video

card as I write this message and I triple checked the connection of this one in my computer and there's no extra power supply to be

connected here.

 

Now I'll resume the 2 "techniques" that I've tried to fix the problem.

 

#1- This one was to do as the AMD technician told me. Downlaod the "Catalyst 14.4& Graphics Driver Installer for Windows XP 32-Bit" from

http://support.amd.com/fr-fr/download/desktop?os=Windows%20XP%20-%20Professional/Home&RenderOnServer=true . Clean uninstall all old

drivers with DDU (Display Driver Uninstaller) because the “AMD Clean Uninstall” application that the technician suggested wasn't

compatible with Windows XP 32bits. Then proceed to install with the help of the "How-To Install AMD Catalyst™ Drivers For A Windows®

Based System" guide from http://support.amd.com/en-us/kb-articles/Pages/catalyst-windows-install.aspx. All things that I had already

tried on my own minus the clean uninstall with DDU and the step by step guide...All went well till the end of the installation where I

should of had a prompted message to reboot my computer as in last step (11 th) of the guide. So I manually rebooted my computer and

realized that my device manager was still showing me that I was using the generic video driver. Note that no message of errors of any

sort ocurred during or after the installation.

 

#2- This one was to after step #1 do a clean uninstall (again) and restart the installation process of the "Catalyst 14.4& Graphics Driver

Installer for Windows XP 32-Bit". But this time after the files were unzip at there default location I aborted the installation process to

go in my device manager and manually upgrade my driver for the video card by selecting a path to search from the unzipped files. Yes the

".inf" files were there and no this didn't work either. I found this technique on Internet forum with someone who seemed to have the same problem but with a

different video card and newer OS (7).

 

So it seems that Windows XP PRO (32bits) is somehow a problem in the equation...

 

Any help would be really appreciated.

 

 

Thanks

Outcomes