AnsweredAssumed Answered

Flickering colors after driver installation - RX480

Question asked by aldec on Oct 23, 2016
Latest reply on Oct 25, 2016 by amdmatt

Hey guys,

I bought a new pc with an ATI RX 480 8GB, build it together, installed newest drivers and played some Battlefield 1. Everything was smooth and fine.

 

The next day I started the system, I got randomly flickering colors during the log-in screen which made it impossible to see anything on the screen. When I blindly typed in the password and got to the desktop the flickering stopped and I could play some more Battlefield 1.

Today the flickering happened on the desktop too and now I even got 2-3 bluescreens which say "VIDEO_TDR_FAILURE cause of problems atikmpag.sys". Between the flickering colors I can see the screen normally for around 1-2 seconds. I followed the troubleshooting (DISM, SFC, driver cleanup and installing new drivers) but the problem still occurs. I tried different driver versions (16.10.2, 16.9.1, 16.8.2) but nothing seems to help. Right now I can use the system only during windows safe mode. Does anyone have a solution for this problem?

 

Regards,

aldec

 

//edit: I tried my old Radeon HD 7870 and everything is working fine with it. Is it a hardware issue with my new RX 480? Because it worked the first 1 1/2 days perfectly and the problems only appear after installing the drivers.

 

System:

-Sapphire RX 480 Nitro+ 8GB

-Desktop system

-Windows 10 Enterprise 64bit

-Currently Crimson Edition 16.10.2 installed

-Display is BenQ GL2450 (1920x1080) HDMI to DVI adapter

-Motherboard Gigabyte GA-Z170-HD3P

-CPU is Intel i5 6500

-PSU is be quiet! Pure Power 9 CM 500W

-RAM 8GB

Outcomes