3 Replies Latest reply on Oct 22, 2016 11:21 AM by metalquintessence

    RX480 Randomly Freezes the PC when playing Games in Fullscreen

    metalquintessence

      I have already reported the issue and will maybe file a support ticket.

       

       

      I have build a brand new system with a fresh OS Win 8.1 install.

       

      I have checked hardware components for malfunctions, but everything seems to work fine. Ram passed any test, there aren't any other issue, apart when I try to play games in fullscreen with the latest drivers and the lacking features in the previous version.

       

      I use a certified Accell DisplayPort cable with a Samasung S24E370DL and PowerColor AXRX 480 Red Devil. FreeSync works perfectly with, so I doubt there is any problem.

       

       

      I have done multiple clean driver uninstall and re-installs.

       

       

      Basically it comes down to this.

       

      When I upgrade to the Crimson Edition 16.10.1 Hotfix I can access all the settings, but games crash in full screen mode. Any game.

       

      When I use the Crimson Edition 16.9.2 I can't access the display tab, bcs the client crashes. Also the Wattman is completely unoperating. Everything is greyed out, you can't change any settings and I think it isn't fully loaded.

       

      After I install the Crimson Edition 16.10.1 Hotfix any game running in full screen mode causes the computer to hang with the picture freezing while the music is still playing. For the first minute or two I can move the mouse and the lights of the keyboard works, but after that the mouse cursor and the keyboard lights become frozen and non-responsive as well and after that the music also stops playing and that's how the PC stays unless I hit the reset button or force shut down. It won't even run a normal shut down procedure. A complete lock down.

       

      I don't have the issue with the previous driver version (Crimson Edition 16.9.2), but there I can't access the display settings in the Crimson software, bcs the crimson client crashes when I hit the Display button. And the Wattman app is opening, but every option there is blank/nonfunctional.

       

      When I upgrade to the Crimson Edition 16.10.1 Hotfix I can access the display and the wattman settings and everything works there, but I get games crash in full screen mode.

       

      I have tested Ram for errors and it passed every test, memtest was the first I tried and did perfectly there.

       

      Then I checked whether something else like overheating could be the reason, despite the system would've probably rather re-booted/shutdown than hang like that. But every time I had the game would hang in full screen I had the Afterburner with RivaTuner and HWinfo running and every reading was perfect. The temps (highest I've seen was 70C, but usually hovers in the 50's and 60's C), frequency, voltage all were showing normal readings through out all the time. I had Windows show me an error screen during reboot after some of the freezes with a message that they are collecting info and the reason for the crash was a driver of some sort. I guess it's the video card drivers hence when I revert to the previous version everything works.

       

      I also tried switching the GPU on-board BIOS, but that didn't change anything. Same behavior both modes, silent and OC.

       

      Given that others with the same card, but from a different manufacturer also has this problem I think the drivers are the culprit.

        • Re: RX480 Randomly Freezes the PC when playing Games in Fullscreen
          metalquintessence

          Update:

          The issue appeared in the older drivers as well, hence I updated to the latest drivers. The issue still remains in any fgame/program.

           

          Ran 3dMark, Firestrike passed.

          Ice Storm got stuck right from the beginning.

           

          Funny thing is that the picture freezes, but the sound and everything else seems to work, bcs I could hear explosions and the keyboard Caps Lock was working. I refreshed the Monitor sources and the DisplayPort returned signal, but the picture was stuck at this single frame.

           

          I waited for the test to finish, hoping it will fix itself, but nothing happened.

           

          And when I try bringing task manager up everything stops working. The keyboard lights even. You can't turn off the PC with anything but a hard reboot/reset. Until I try starting task manager everything works tho, except for the stuck picture. -_-

           

          I am really getting frustrated.

          I've never had anything like this. I guess I will justfile a support ticked with AMD and prolly with PowerColor too. And will try and see if I can test with a live OS and/or VM ware.