2 Replies Latest reply on Dec 15, 2016 8:47 AM by barrylegg

    3DS Max 2017 under bootcamp on iMac Retina 5k: Fans running at full speed?

    barrylegg

      Hi - first post here. Apologies if this has been covered elsewhere.

       

      I'm running 3DS Max 2017 on an iMac Retina 5k (late 2014) with Radeon R9 M295x (4gb) under Windows 10 in Bootcamp.

       

      Everything appears to be running ok, but I'm slightly concerned about why the fans run at full-speed the moment 3DS Max is open. They will run at full-speed even when Max is doing nothing, sitting at an empty scene.

       

      I've checked the task manager, and Max is not hitting the CPU hard at all, so it's unlikely to be the CPU fans which leaves me to believe it's the GPU fans. I can't get any feedback about the level of work my GPU is doing - is there a good utility for it? The only AMD utility I've tried says the GPU is doing 0% work all the time which... can't be right.

       

      Anyone having this issue? I'd appreciate a decent utility from AMD or Apple to effectively help monitor GPU activity for the Mac-edition AMD cards.

       

      Kind regards,

       

      B.

        • Re: 3DS Max 2017 under bootcamp on iMac Retina 5k: Fans running at full speed?
          amdmatt

          The application uses GPU acceleration so i suspect it moves the GPU into a higher clock state than at idle, which revs up the fans. Check with the developer if it is possible to disable hardware acceleration to avoid this.

          • Re: 3DS Max 2017 under bootcamp on iMac Retina 5k: Fans running at full speed?
            barrylegg

            Ok - after a while away from Max, I revisited this problem and solved it myself.

             

            There is no reason for the fan speed on this machine to be running as high as it is in 3DS Max, even when displaying at 5k, when the software is doing nothing.

             

            Two sets of default options need changes:

             

            1.The Max viewport driver settings need tweaking from their defaults, and you should do this while running Max as administrator or the changes you make will not stick.

            2. Certain default viewport settings are not good for 5k display and require changes - these may require changes on a case-by-case basis.

             

             

            1. Changing Viewport Driver Settings:

             

            Go to; Customize > Preferences > Viewports tab.

            Choose driver - set to 'Legacy Direct3D.' (I have experimented briefly with 'LegacyOpenGL' but not had the same success as with Direct3D - your experience may differ).

             

            Simply activating this driver improves performance massively, but some further improvements can be made via the configuration options for it:

             

            In order to configure this driver, it needs to be active, and it won't become active until Max is restarted, so restart Max now.

             

            Go back to: Customize > Preferences > Viewports tab.

            Go into 'Configure Driver'

            Ensure these options are checked:

             

            Display All Triangle Edges

            Use Cached D3DXMeshes

            Use Wireframe Faces

            Use Triangle Strips

                 For Wireframe Objects.

             

            The 'Window Updates' section should be adjusted according to how you use Max - particularly whether you are using it in single or multi viewport mode.

            See here for details: https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/3DSMax/files/GUID-4FB6180F-7C21-4B0E-903B-D25974C92FB7-htm.html

             

            Configure Direct3D Dialog | 3ds Max | Autodesk Knowledge Network

             

            Recommended: Do enable 'Anti-aliased Lines in wireframe views' - without this enabled, Max will display edges so finely that they are almost invisible on a 5K display.

             

            Enabling further anti-aliasing is up to you, but will lead to a performance hit, so I leave it off.

             

            THESE CHANGES WILL REQUIRE MAX TO BE RESTARTED BEFORE THEY COME INTO EFFECT.

             

            I've also set up an application-specific profile in AMD Crimson with a few minor adjustments but I'm not convinced they are doing much just yet. Will experiment further.

             

            2. Change default viewport settings

             

            After changing and configuring your viewport drivers, go into a Max viewport and click the little '+' icon in the top left corner of the viewport.

            Choose 'Configure Viewports'

             

            Use these settings:

            1.PNG2.PNG

             

            Finally - you may want to see below to see how to enable your scene statistics so you can view how well your viewport is running. I now get over 200fps with moderately full scenes and the GPU is doing far, far less work and the fan is not spinning all the time. I'd like to be able to cap the FPS at 60 so the GPU is doing even less work, but I can't figure how to do that. Let me know if you do.

             

            3.PNG

             

             

             

             

            1 of 1 people found this helpful