6 Replies Latest reply on Oct 15, 2016 1:18 PM by qwixt

    Grim Fandango remastered

    pvangendt

      I have a windows 7 x64 system with Radeon HD4670. Grim Fandango complains about OpenGL functionality missing when starting. I tried everything I know, used the AMD searcher, Guru3D driver cleaner, and tried to install appropriate driver according to AMD but always with error messages. Also tried to put opengl.dll next to grimfandango.exe which helped people at steam apparently, but following the installation instructiosnfor opengl.dll at some site (fix4dll or some I guess) was unable to deregister and register opengl.dll, probably because of missing dependencies, sigh.

      Gaming should be fun, this is not :-(

        • Re: Grim Fandango remastered
          amdmatt

          The HD4xxx series has reached peak optimisation and been moved to legacy status, there will not be any further driver updates for your product. More information available here.

           

          The last Catalyst driver for your system is 14.4 WHQL and is available here.

           

          I would recommend using DDU to sweep your system of AMD drivers, and then trying the drivers above to see if they resolve your issue.

          1 of 1 people found this helpful
            • Re: Grim Fandango remastered
              pvangendt

              Hi Matt,

               

              Could you enlighten me about the OpenGL capabilities of my card. I read somewhere it should support version 3.3, so that would be enough for this game. Is that correct?

              If yes, what could be the OpenGL problem I have?

               

              Thanks,

               

              Peter

                • Re: Grim Fandango remastered
                  qwixt

                  According to google, OpenGL 4.4 support. So install 14.4 properly, and see if that fixes your issue. I suggest using DDU to uninstall in safe mode, then re-install 14.4. After installing, you can go to Steam->Help->System Information to opengl level. This is what mine has

                   

                  Video Card:

                      Driver:  AMD Radeon (TM) R9 Fury Series

                   

                   

                      DirectX Driver Name:  C:\WINDOWS\System32\DriverStore\FileRepository\c0307101.inf_amd64_4e33c7b9edea4480\aticfx32.dll

                      Driver Version:  21.19.137.1

                      DirectX Driver Version:  21.19.137.1

                      Driver Date: 16 Sept 2016

                      OpenGL Version: 4.5

                      Desktop Color Depth: 32 bits per pixel

                      Monitor Refresh Rate: 75 Hz

                   

                  Oh course this is a different card, but you get the idea.

                    • Re: Grim Fandango remastered
                      pvangendt

                      Thanks qwixt, didn't know about the Steam system info. Mine says I have OpenGL 2.1 so that may be the problem.

                      I go and try to fix it according to your instructions and will let you know.

                        • Re: Grim Fandango remastered
                          pvangendt

                          No luck yet. I have setup problems. First error message "Failed to load detection driver" could be solved bu running Ccleaner after failed setup. Now I have tried 13-9-legacy driver recommended by AMD as latest driver for my card. It complains about missing INF file, setup fails. Then 14.11 beta... same problem. Then 15,7,1 catalyst setup, does not complain but no driver is installed and it tells me there are warnings after setup.

                          In each case I cannot view the log, it simply odes nothing when I click that button.

                          Each setup now I first run DDU in safe mode, reboot, then run CCleaner is dafe mode, reboot, then rn the catalyst/driver setup in normal mode and it faisl each time and I can't see the log so I can't figure out what went wrong.

                          And by the wat I can't find that 14.4 setup.

                            • Re: Grim Fandango remastered
                              qwixt

                              I did not look into more after amdmatt said 14.4 was the latest. I just assumed 14.4 was correct. It actually appears that 13.9 is the last supported driver for your video card. I could not find the opengl version supported by 13.9. If you had 13.9 installed when Steam report OpenGl 2.1, then you might be out of luck.