1 Reply Latest reply on Oct 3, 2016 12:14 PM by ray_m

    Fifa 17 requires at least 16.3 driver version

    leonardobertini

      Hello everyone.

      I have a problem with proper working Fifa 17.

      When I am running Fifa 17 appears a statement that game requires at least 16.3 driver version and with my version of driver could be problems with proper working of game.

      I have a AMD Radeon HD 5800 Series, Windows 7 64-bit.

      When I downloaded tool to automatically detecting and instal driver from AMD support website this tool searched a 15.2 version as the latest and current version.

      While running Fifa 17 with 15.2 version driver game was aborted during loading screen.

      how can i do?