19 Replies Latest reply on Oct 6, 2016 11:46 AM by colesdav

    AMD R9 290X (Crossfire) GPU2 Core Clock?

    tauske

      Graphics:
      AMD R9 290X (8GB)
      AMD R9 290X (8GB)
      (Crossfired)

      CPU:

      AMD FX(tm)-9590 8-Core Processor

      RAM:

      32GB DDR5

      Motherboard:

      Sabertooth 990FB R2.0

      Operating System:

      Windows 10 64 Bit System

      Radeon Software Version:
      16.6

      Dual Monitor Setup:

      Acer G246HL 24-Inch Screen LED-Lit Monitor

       

       

       

       

      This isn't a new build by any means, had it for a while, but I've always wondered about my GPU Clocks, never thought to ask till now I guess though.
      When I am running my Cards the main Card runs on Max Core Clock when I am in games, or watching video's or whatever, but the GPU 2 clock never goes above 300?

      I've tried this Crossfired, and I've tried this with Crossfire Disabled and 1 Monitor plugged into each Graphics Card, the situation never changes. I boot the PC on, both Core Clocks go straight to 300, then when I start gaming, or watching video's, whatever I am doing for my entertainment at the time, my main GPU1 Clock will spike up to Max, but the GPU2 Clock never goes above the Default 300?

       

      (I am using MSI Afterburner to see these results)

        • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
          jissu

          Had the same problem. Fixed it by reinstalling drivers.

          • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
            Earnhardt

            running those 2 cards in crossfire at 1080 is a waste,those cards should be running 1440 monitors to utilize them.

            • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
              colesdav

              Hi,

               

              (1).  Make sure you turn off and or disable all other GPU Control / Monitoring Programs such as Asus GPU Tweak, Sapphire Trixx, MSI Afterburner.

              (2). Make sure you are driving your display(s) from your Primary GPU (Usually the card in the main PCIex16 Slot on the MB.  The Secondary card should have no outputs connected.

              (3). As an initial test with your current AMD Crimson Driver. Turn off Crossfire in Global Settings. Turn on Crossfire in Global Settings. Set AMD Crossfire Logo to ON.

              (4). Find a Game that you know supports Crossfire (Example, Crysis Series, Borderlands 2, "The Division"). Start your game.

              (5). When you launch your game in Full Screen Mode you should see the AMD Crossfire Logo in the top right hand side of the screen. If you have a second monitor display attached to your primary GPU then you will be able to have AMD Crimson open in that Display and you will see activity on the second GPU.

              (6). If you have turned Crossfire on, and you do not see the Crossfire Logo when it is enabled then Crossfire has not initialised properly.

              (7). If Crossfire has not initialised properly then either the game does not support it at all, or the game needs a specific crossfire profile set or the game did not launch in fullscreen mode.

              (8). If the game does not launch in Fullscreen Mode then you can press ALT Enter at the same time to switch the game between Fullscreen Mode (needed for Crossfire). and Windowed Mode.Or you can use the game menus. 

              (9). If the game launches in Fullscreen Windowed mode, my recommendation is to set it to windowed mode first, at the same resolution you want in fullscreen,  then set it to fullscreen mode to enable crossfire.

              (10). If the above did not work for you then I would do the following.

               

               

              (11). Normal check would be to double check Crossfire Bridge is connected but ... you don't need separate crossfire bridge for this card. Here is an article on Crossfire X: AMD Radeon R9 290X To Feature New AMD CrossFireX Technology - CrossFire Bridge Not Required Anymore

              (12). Double check the motherboard BIOS settings have both PCIe Slots you are using set to the correct PCIe speed and settings. If these are not of correct bus width and bandwidth then you might see problems with CrossfireX.

              (13). Uninstall your current AMD Driver using Prorgrams -> Uninstall. Then Reboot your PC.

              (14). Download and run: AMD Clean Uninstall Utility.

              (15). Reboot your PC. Install the latest AMD Drivers for your OS and cards. 

              (16). Reboot your PC. Check your New Driver can see both cards. Repeat tests (1) - (10).

               

              Hope this helps.

              Bye.

              colesdav.

                • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
                  tauske

                  Hello Colesdav,

                   

                  The crossfire works, I can guarantee this for a fact I actually do launch Crossfire games with the Logo turned on all the time unless it's a game specifically where the logo covers important info then I disable it for that game.
                  My problem isn't getting Crossfire to initialize, it's that my GPU2 Coreclock never seems to change above 300 which has me concerned. I've tried running games in crossfire mode. Doing normal tasks.
                  Even with my Cards not crossfired and 1 monitor plugged into each card individually running the same applications on both monitors 1 card spikes up to MAX core clock and GPU2 stays on 300 with them running same applications at same time. (Dunno if this would make a difference but something I tested)

                   

                  This is my first time running a 2 card setup so I dunno if I'm missing something simple or?

                    • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
                      colesdav

                      Hi,

                       

                      Can I ask you if you did try this from my earlier email ?

                       

                      "(1).  Make sure you turn off and or disable all other GPU Control / Monitoring Programs such as Asus GPU Tweak, Sapphire Trixx, MSI Afterburner."

                       

                      "(12). Double check the motherboard BIOS settings have both PCIe Slots you are using set to the correct PCIe speed and settings. If these are not of correct bus width and bandwidth then you might see problems with CrossfireX.

                      (13). Uninstall your current AMD Driver using Prorgrams -> Uninstall. Then Reboot your PC.

                      (14). Download and run: AMD Clean Uninstall Utility.

                      (15). Reboot your PC. Install the latest AMD Drivers for your OS and cards.

                      (16). Reboot your PC. Check your New Driver can see both cards. Repeat tests (1) - (10)."

                       

                      Another point. Did you make sure you Disable ULPS?

                  • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
                    colesdav

                    Are you running F.Lux? If you are you need to turn it off in Windows 10 to let Crossfire work.

                    • Re: AMD R9 290X (Crossfire) GPU2 Core Clock?
                      colesdav

                      Here is a nice review that pointys out what you should see:

                      Sapphire R9 290X Tri-X 8GB CrossFireX Review - eTeknix