3 Replies Latest reply on Sep 30, 2016 4:42 AM by benman2785

    Display/resolution issues with RX480 after installing driver

    spluff

      So I recently put together a new build on W10 with a Sapphire RX 480 4G NITRO. Everything was going smoothly until it came to installing the display drivers. Once I had installed Crimson (I tried both 16.9.1 and 16.7.3) however, the screen suddenly was near unreadable, with bizarre colours and vertical lines covering the screen. The display issue looks a lot like what occurs when a screen is set up with an incompatible resolution, however, I have checked repeatedly that it is set to 1920x1080 (the native resolution of the monitor) - and none of the other resolutions I tried seemed to make it any better. It also looks like the display might be stretched too far horizontally (though it's hard to tell with such an unreadable screen). I have attached a photo of the issue.

       

      I was able to somehow fix the issue in the home screen of windows by playing with settings in Crimson. I'm not entirely sure what exact setting fixed it (because it was largely unreadable) but the first progress was made by turning on Virtual Super Resolution. However, it somehow works now with Virtual Super Resolution turned off and the resolution still set to 1080p. At this point, I brushed it off, continued on with setting up my PC - however, after installing my first game, the same issue occurs and the only way I can fix it is by setting the game to run in windowed mode. This is, obviously, very annoying, and makes me suspect something is not quite right with either my settings, the card, or the driver and I'd like to get to the bottom of it.

      The screen I am using is an old Acer X243h if that might be causing the issue (though if it were the screen it seems odd that I wouldn't encounter the issue BEFORE the driver was installed)

       

      Thanks in advance for any suggestions.

        • Re: Display/resolution issues with RX480 after installing driver
          benman2785

          1. uninstall GPU Driver with DDU in SAFEMODE

           

          2. Restart

          3. clean install of 16.7.3 OR 16.9.2

           

          if error still persists its either the PSU (not enough power to your GPU) or your GPU is damaged (maybe because of OC - or damaged from factory)
          usually with this error i think its the GPU that is damaged -> if DDU doesnt work use warranty of your vendor

          1 of 1 people found this helpful
            • Re: Display/resolution issues with RX480 after installing driver
              spluff

              Thanks for that. I tried a reinstall using DDU to clear it in safe mode, same issue occurring unfortunately. Weird thing is that it has no problem at all actually running the games provided they're in borderless windowed mode.

               

              Everything is installed at factory defaults (ie. I didn't overclock anything).

               

              Is there any way of ensuring it's not the PSU before I return it (beyond physically testing it with a multimeter - which I don't have)? I'm using an Antec Neo Eco II Bronze 550W which I believe should be more than sufficient.

               

              If it helps at all, the rest of the PC specs are: Gigabyte GA-B150M-D3H, i5-6500, 16 gb 2133 DDR4, Sandisk 240GB SSD Plus, WD Blue 1TB, and I re-used an old ODD and a Xonar DX sound card.

            • Re: Display/resolution issues with RX480 after installing driver
              benman2785

              can you provide a picture of your screen? and make an screenpicture via windows ans save it in paint to see if only your screen is broken

               

              but usually if DDU didnt help and GPU error still persists you should RMA