1 Reply Latest reply on Oct 3, 2016 4:38 AM by amdmatt

    RX 480 "Display Driver stopped responding and has restarted" error. TDR fix did not work

    phantomknight321

      I am having issues with my brand new Sapphire Nitro + RX 480 4gb. For some reason, usually randomly but it is aggravated by opening the Radeon Settings menu, I am getting the "Display Driver Stopped working and has recovered" error. For what its worth, I had to disable the motherboard splash screen because it was getting displayed all corrupted since I put the new card in, but I read that can be a gigabyte issue.

       

      Here are my system specs:

       

      CPU: Phenom ii 960t with unlocked cores (x6)

      GPU: Sapphire Nitro+ RX 480 4gb

      Motherboard: Gigabyte 970a-ud3 Rev. 1.1

      PSU: OCZ ZT 750 watt

      OS: Windows 10 64 bit

       

      I originally had Windows 7, and I installed the drivers just over my existing ones. Tried running a heaven benchmark (to compare results to the 6970 I replaced) and it crashed right before it finished, but it looked great the whole time until that point. Then I totally cleaned the drivers out with DDU, reinstalled the latest drivers, then started seeing the "Display Driver stopped responding and has restarted" error, especially when I would go into the Radeon Settings menu. So I reformatted and installed Windows 10, same issues. Updated Motherboard BIOS, reinstalled windows 10 again (Since the BIOS update reset the factory defaults) and still have the issue. When it happens, usually I have the radeon settings open and the program crashes and is unusable.

       

      Any Ideas from anyone?

       

      *EDIT* I should mention I have tried the latest hotfix drivers and the version just before that so far

       

      Message was edited by: Robert Lacy