AnsweredAssumed Answered

Sapphire RX 480 Nitro+ 4GB crashing/artifacting, driver issue or faulty card

Question asked by jerryy on Sep 20, 2016
Latest reply on Oct 13, 2016 by jerryy

Hello,

 

I have the following issues with my new sapphire rx 480 4gb nitro card,

 

unfortunately, almost all my games are artifacting and crashing

 

mostly it crashes with the error "directx function get device removed reason failed with dxgi_error_device_reset" in nearly every game I have tried with it.

 

i have installed new windows, tried with diferent drivers (16.7.3/16.8.3/16.9.1) tried with diferent monitors and cables,- DP/dvi/hdmi,tried raised the power limit in wattman/sapphire trix app,

 

tried with amd compatibility mode on/off and freesync on/off, tried on 60/100/120/144hz refresh rate, eventualy i pluged the card in diferent computer (same issue) nothing helps...I don't think its driver issue or my rig because i have

 

tried with following cards windforce gtx 970, powercolor pcs r9 380, asus gtx 980ti strix, all working fine.

 

any suggestion before i start RMA process?

 

My rig: (nothing is overclocked)

 

CPU: i7 3770K

MBO: Asus P8Z77-V Deluxe

RAM: Kingston HyperX Fury 16GB 1866Mhz

SSD: Kingston V300 120GB

HDD: WD Blue 1TB

GPU: Sapphire RX 480 Nitro 4GB

PSU: Corsair AX860

MONITOR: AOC G2460PF 144Hz Freesync

OS: Windows 10 x64

 

picrures with crashes/artifacts

 

video with arifacts in rainbow six siege and dragon age

 

https://www.youtube.com/watch?v=m2Fys8rhJ5g

 

https://www.youtube.com/watch?v=iLkzfFv0RMU

Outcomes