12 Replies Latest reply on Sep 26, 2016 8:45 AM by mexgt

    RX480 Blackscreens / Weird Activity @ Wattman

    mexgt

      So I've been playing World of Warships and the games crashes constantly, it just blackscreens and need to force close the game, sometimes it does it constantly one time after another. I checked the game with wattman open and the Activity (green bar) is all over the place, same with Starcraft 2 but with unigine heaven 4.0 its stable 99% of the time, so whats going on?

       

      Radeon Software Version - 16.9.1

      Radeon Software Edition - Crimson

      Graphics Chipset - Radeon (TM) RX 480 Graphics

      Memory Size - 8192 MB

      Memory Type - GDDR5

      Core Clock - 1303 MHz

      Windows Version - Windows 10 (64 bit)

      System Memory - 16 GB

      CPU Type - Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz

       

      -----------------

       

      Radeon Settings Version - 2016.0907.1109.18253

      Driver Packaging Version - 16.40.2011-160907a-306790C

      Provider - Advanced Micro Devices, Inc.

      2D Driver Version - 21.19.134.1

      Direct3D® Version - 21.19.134.1

      OpenGL® Version - 21.19.134.1

      OpenCL™ Version - 21.19.134.1

      AMD Mantle Version - 21.19.134.1

      AMD Mantle API Version - 98310

      AMD Audio Driver Version - 10.0.1.0

      Vulkan™ Driver Version - 1.3.0

      Vulkan™ API Version - 1.0.21

        • Re: RX480 Blackscreens / Weird Activity @ Wattman
          kisushi

          You should install the driver version 15.7.1 since the 15.11 is crimson this all started with crimson.

          RMA might not solve the problem since people here RMA twice and the problem persisted

          YOU should do what is bellow:

          First you should uninstall the driver, then use DDU and AMD Clean Uninstall Utility.

          Then install the previous driver manuallly in the device manager and use Sapphire Trixxx Utility and put, go to the fans settings and click fixed and put them to 100%.

          The problem is happening i think is that Since Crimson drivers were introduced they didn't fixed a bug that is causing overheating on the GPU's, that bug is that they fans speed is my default at 20% power and it doesn't moves even when you play, causing it titco overheat and malfuntion.

          Also try using Memtest to see if ram has any problems.

          Use Furmark if you can stable your system to check is the GPU is fine

          You can also update your VBios to the latest version, it could help.

          Windows 10 Aniversary Update is causing major issues as well i recommend either disable the automatic updates if you didn't install update or do a clean install of windows and disable the automatic updates after installation.

          Users here said that overvolting or downvolting the memory ram could solve it, but that was just for a few users.

            • Re: RX480 Blackscreens / Weird Activity @ Wattman
              mexgt

              Thanks for the reply, but the GPU isnt over-heating, atleast wattman indicates the card hovers in the 60-65*c all the time, it doesnt blackscreens cause of over heating, well thats what I´m assuming, will look for the 15.7.1 drivers though!

              • Re: RX480 Blackscreens / Weird Activity @ Wattman
                mexgt

                AMD 15.7.1 doesn't support RX series, just checked.

                 

                http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-7-1WINReleaseNotes.aspx

                 

                 

                Any input from forum mod or customer service would be appreciated too, thanks!

                  • Re: RX480 Blackscreens / Weird Activity @ Wattman
                    kisushi

                    Thanks to ifixt for the Guide Solution:

                     

                    The Ultimate Solution, dedicated to alpere, without his assistance this would not have been posted.

                    Disclaimer: Not the Nazi one.

                     

                    Problem definition: After loading the crimson drivers for your video card, your system cannot get into windows again with black screens or lines running down the screen etc. If a system driver or application is related is bugged this can occur. The fact your display is ok at bios and until after logging into your operating system is usually a clear indication of a software not a hardware issue.

                     

                    Why: In this case it appears Microsoft recently made some changes to the operating system, AMD introduced wattman a new style of overclocking designed around the new 14nm architecture RX 480's this is affecting not only RX480's but older cards like my 260x. There is a known bug also with a failed overclock wattman does not reset and your forever booting with a well overclocked GPU. Hence the black screens etc. and the fan, lets not mention the fan but on some that's being disabled and if you don't apply a fan setting your cooking your GPU.

                     

                    I'm doing this from memory as I have already fixed my PC with this work-around please give feedback if it works for you or not.

                     

                    The fix.

                    Get stable and into windows again.

                    Boot into safe mode. http://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10

                     

                    I did the shift restart I was just able to see things occasionally and it took several reboots.

                    If you don't have an SSD you could try the F8 option it would be easiest.

                    Or a recovery usb stick

                     

                    Once in safe mode hold your windows key down and press your pause break key or navigate your way to system.

                    Click device manager

                    expand Display adapters

                    Right click on your display adapter , click uninstall, check the delete driver software for this device checkbox and click ok.

                     

                    When it's finished uninstalling the display adapter reboot normally.

                     

                    Once your back in windows after login

                     

                    Hold your windows key and press the Pause/break key or navigate your way to system.

                    Click Device Manager

                    expand Display Adapters

                    Right click on whatever display adapter is currently installed and click update driver software.

                    Click Browse my computer click the top one browse and navigate to

                     

                    presuming you have downloaded the latest driver and have run it's installation navigate your way to

                    C:\AMD\Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-16.9.1-Sep7\Packages\Drivers

                    Click ok

                    Ensure the include subfolders check box is ticked and click next.

                     

                    it should load just the driver now without all the third party stuff AMD incudes in their downloadable executable installer

                    The drivers themselves do the work and all your applications/games should not be affected.

                     

                    To ensure your cards set properly and fan is operating properly since AMD OC and utilities are broken we need a third party program.

                     

                    I recommend Saphires Trixx. Only because I think it simpler and more user friendly for those new to setting there GPU up.

                    But there is also a more technically upmarket MSI Afterburner and other utils out there depending on your GPU's manufacturer on there support page normally.

                     

                    Search google , take your pic, and install your choice.

                     

                    Set your GPU settings memory, gpu clock etc, and fan speeds using you preffered app, consult the help forums and guides for how to's on that. Just make special care to ensure there is a fan setting and the fan is functioning as it should. IE is not stuck at 20% or less. I set my one to run at 81% all the time. I have no issues but each persons choice here is their own. Just use common sense.

                      • Re: RX480 Blackscreens / Weird Activity @ Wattman
                        vonchen

                        As far as I can see, OP's problem is while gaming with World of Warships, not booting into Windows.

                        1 of 1 people found this helpful
                          • Re: RX480 Blackscreens / Weird Activity @ Wattman
                            mexgt

                            Exactly, only WoWs, I downloaded the driver that was released today, and still the same thing    I am in windows perfectly fine, never freezes (knocks on wood) just randomly at WoWs, sucks cause the old Nvidia NEVER gave me a problem, had to upgrade for a better gpu for multi screen support (not eyefinity) and my main screen has Freesync, thats why the RX480 now this problems, BAH !

                              • Re: RX480 Blackscreens / Weird Activity @ Wattman
                                vonchen

                                I do not really have any gaming issue so I am afraid can not help you on this side.

                                But it seems only game crash not entire PC in your case, so I can only suggest not to use wattman in background while gaming.(afterburner seems fine)

                                 

                                I have similar issue on TOS(Tree of Savior , online game). If I use GPU-Z or something like while I am playing TOS, it will randomly crash.

                                I closed GPU-z and it runs fine since that.

                                 

                                If this did not help you, maybe try to report to WoWs or AMD, sadly to say that's only thing we can do as a user.

                      • Re: RX480 Blackscreens / Weird Activity @ Wattman
                        vonchen

                        The weird activity diagram is not the root cause on your problem. It is a common phenomenon(I do not know if it is an issue or not) on RX400's and new wattman.

                        I have RX460 and have the same weird activity diagram, but I do not have issue on gaming.

                         

                        You can use afterburner4.3.0beta14 and enable "unified GPU usage monitoring" , so you will see more stable diagram on afterburner.

                        As for wattman no way to change it.

                         

                        But if you use afterburner in background , be careful to this issue:

                        rx 480 fan going to 100%

                        I avoid this issue by not to watch video while using afterbutner.

                         

                         

                        EDIT: it seems from R7/R9 have the same phenomenon.

                        https://www.reddit.com/r/Amd/comments/3ybkna/is_it_normal_my_gpu_usage_jumps_from_0_to_100/

                        Rx 480 activity 100 to 0%

                        • Re: RX480 Blackscreens / Weird Activity @ Wattman
                          mexgt

                          still no official news in this case, or something that is being worked on! Think I remember why I was only using Nvidia