5 Replies Latest reply on Nov 16, 2016 12:08 PM by toxiccharged

    R9 290 using DP1.2 4K most of the times not showing 60Hz

    toxiccharged

      Hey,

       

      A few weeks ago I bought a new 4k monitor (LG 27UD58) and while my R9 290 is able to show 4k, it sometimes just won't display this resolution in 60Hz.

      Every time when I'm booting my PC it's a surprise whether my GPU will display 4k in 30Hz or 60Hz. I also used CRU to try and fix this but without success.

      I also tried reconnecting my GPU and reinstalling the drivers with the usage of DDU. I even tried to patch the pixel limit but since I'm using DP and not HDMI this didn't help anything like expected.

      I'm using DisplayPort 1.2 and I already enabled the DP1.2 settings in my monitor. When my gpu displays 60Hz the image quality also perfectly fine without artifacts etc so my gpu is capable of displaying 60Hz but sometimes just won't. Why is my GPU behaving like this?

      I already saw some different topics with people having the same problem but without a real solution. Is the RX 480 also behaving like this?

      If it's a problem with my card then I will just replace it with a RX 480. While my card is capable of running some games in 4k @>30fps, it also isn't really comfortable to work with windows in 30Hz.

      While this doesn't have to be fixed immediately, I would like to solve this shortly because it's just not working very pleasant this way.

       

      My specs are

      • Graphics Card
        • R9 290
      • Driver version installed
        • Radeon Software Crimson Edition 16.9.1
      • Display Device
        • LG 27UD58
      • Motherboard
        • Asus H97 Pro
      • CPU/APU
        • Intel Core i5-4590 CPU @ 3.30GHz
      • Operating System
        • Windows 10 Pro x64
      • RAM
        • 8GB DDR3 1600MHz

      I hope someone is able to help me and thank you very much in advance for any possible helpful answer!