andrecirillo

R9 380 black screen crash FIXED at last by fixing/locking the gpu clock

Discussion created by andrecirillo on Sep 12, 2016
Latest reply on Oct 6, 2016 by maxhardy

amdmatt

 

Hi guys, I've went through hell trying to solve this annoying crash and tried a lot of stuff and tested a lot of drivers versions.

 

What really solved my problem was to use msi afterburner (with overclock extended option and without power play) to set the clock to 970MHz or any other value different from default gpu clock (980MHz in my case with the PowerColor R9 380 4GB). I've also turned off Power Efficiency in Radeon settings and I didn't change power limit or voltage, I've just changed the clock a little. I've also stopped using fan custom profile to let the card at 40 celsius degrees when idle and at 60 celsius degrees in load. This monster was made to run above 70 celsius degrees, with high resolutions, many video settings on and at full power and speed all the time.

 

With the fixed clock, the game performance is MUCH better and without the clock/power fluctuation the crash also stop happens.

 

I've been playing several games the last 2 weeks with Crimson 16.8.3 WITH NO CRASHES =)

 

So that's it, just use msi afterburner to set a fixed clock different from default gpu clock and be happy enjoying all your card power and performance.

 

 

VERY IMPORTANT: I've tested this setup with Crimson 16.9.1 and the screen goes black but the game don't crash anymore. Sometimes I need to power off and power on my tv or just return to the game after it minimizes. In both cases the games goes back with a lower resolution. So I reverted to Crimson 16.8.3 and everything is fine. After changing the driver, besides using Display Driver Uninstaller tool and removing amd drivers and programs, it's necessary to reboot a couple of times and to reset gpu settings and clear shader cache in Radeon settings to fully remove old driver residues. The guys from amd really made some changes in this new Crimson version and they almost solved the issue. The very secret to avoid the crash is to avoid the clock and power variation/fluctuation fixing/locking the gpu clock.

Outcomes