4 Replies Latest reply on Sep 12, 2016 9:23 AM by skycyclepilot

    Microstutter or Freesync Issue?

    skycyclepilot

      In Far Cry 4, anytime my frame rate drops into the 50s, I'm either getting microstutter, or freesync is not working.  I can't tell which.  It's easiest to see if I face a tree or pole, and move from left to right with the keyboard.  If the frame rate is 60 - vsync is on - everything is smooth.  If I up the game settings so the frame rate drops into the 50s, the smoothness is gone.  As the tree or pole passes from one side of the screen to the other, it will "hitch" a couple of times.  The same hitching is apparent throughout the game, if the frame rate drops.

       

      I've tried every imaginable setting in the Crimson driver - the current version.  I've tried every setting in the game, and nothing helps, except to keep the settings so that the frame rate stays above 60.  That is not why I bought a Freesync monitor, and Freesync video card.  I do know that Freesync is working - I installed the windmill demo, and it is obviously working.

       

      I've tried everything that I can find online - changing settings in the XML file, for example - and nothing makes any difference at all.

       

      I have an MSI RX 480 Gaming X video card, along with an i7-875k overclocked processor, with 16 Gb of RAM, an SSD, and Windows 10 x64.  My monitor is an LG UHD with Freesync - and I've tried the game in all resolutions.

       

      Any ideas???

        • Re: Microstutter or Freesync Issue?
          amdmatt

          Sounds like an issue with the game. I have Farcry 4 myself and it is not always 100% smooth, even when using just one GPU. I would try playing around with the video quality settings, one at a time, and see which one is causing the issue. For me i found lowering Geometry from ultra to Very High or High helped a lot.

            • Re: Microstutter or Freesync Issue?
              skycyclepilot

              Thanks, AMDMatt.  After reading several reviews on Far Cry 4, I have to agree with you.  It's the game engine itself.  Battefield 4 is very smooth, and FreeSync is obviously working in that game.  I'm playing Far Cry 4 at 1080p, with Ultra settings, but with Motion Blur and God Rays turned off - I don't care for either.  Knowing it is probably the game engine itself, I'll live with the occasional stutter, but will try lowering Geometry to see if that helps further.

               

              By the way, I chose the RX 480 for FreeSync, and I chose a FreeSync monitor because G-Sync monitors are obscenely overpriced.  I'd probably rather have a G-Sync monitor, and a GTX 1070, but what working person can afford that?!!!  Keep up the good work, AMD.  May Zen CPUs and the RX 490 video cards finally give Intel and Nvidia the competition they sorely need.  I just wish AMD would get things to market a lot sooner...

                • Re: Microstutter or Freesync Issue?
                  amdmatt

                  Thanks for the feedback.

                   

                  I played Farcry 3 a lot too and that had the same problem. Setting Vsync to either on or off can help, with triple buffering enabled. Try using FRTC as well. I had to tinker around to get things as smooth as possible, but it was never completely free from stutter.

                    • Re: Microstutter or Freesync Issue?
                      skycyclepilot

                      V-Sync on, at 1920 X 1080 has given me the best results.  Strangely, triple buffering, and FRTC didn't seem to help - every system is different, I guess.  Running without Afterburner or RivaTuner also helps - both those seem to introduce stuttering, and not just in Far Cry 4.  I do believe it is the game engine, and, as you experienced, I don't think it is possible to completely get rid of stuttering in this game.  You can run it at a very low resolution with all the eye candy turned off, and it still stutters!  I'm just going to play it, and enjoy it.  It's a great game.