1 Reply Latest reply on Oct 3, 2016 1:31 AM by angieseg1407

    Rx 470: screen goes black for a second

    vacacionero

      I've recently Bought a Sapphire Radeon Rx 470 4gb DDR5 OC

       

      My system is:

      PSU Sentey STY65-POR (650W)

      Motherboard: Gigabyte H97-D3M

      CPU:    Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz, 3100 MHz

      RAM: 8gb

      HDD: WDC WD10EZEX-75M2NA0 (931 GB)

      Windows 8.1 64bit

       

      Randomly, when Windows is idle, when watching videos or playing games, screen goes black for a second or two (sound via HDMI is gone too) then returns inmediately to its normal state

      Installed drivers were 16.7.3 when the problem appeared, then i've uninstalled them via DDU and installed the latest hot fix 16.8.3

      Release notes for 16.8.3 says "Fixed Issues: A random blank or colored screen may be experienced intermittently on some Radeon RX 400 series products while gaming."

      The "fixed issue" appears to be the same, but the problem is still there after the installation

       

      I'm suspecting that psu (only 16A trough +12V rail) may be the problem, but i don't want to change the psu for nothing

      What do you think?

       

      Also Release note says: "A small number of 144hz non-FreeSync enabled displays may exhibit flickering during gaming or on desktop."

      How i can check this? My display is not flickering, the screen goes black for an entire and huge second :-)

       

      Thanks in advance, excuse my bad english, greetings from Argentina