13 Replies Latest reply on Jan 13, 2018 11:08 AM by kingfish

    Crossfire toggle missing in the latest and past few versions of Crimson

    rikans087

      I have asked this question before and it wasn't solved. Please before answering, I am a fairly literate computer person so avoid posting basic-steps on how to access the crossfire toggle. Believe me when i say: it is missing from crimson in all shapes and forms.  

       

      My system:

      Motherboard: Crosshair V Formula Z

      CPU: AMD FX-8370 8-core

      RAM: Gskill DDR3 16gb

      OS: Windows 7 sp1

      GPU: Sapphire Radeon R9295x (two cards on one board)

       

      Crossfire worked fine up until about the spring of this year. Then, every version since, the crossfire toggle has been missing. GPUz shows there are indeed two cards and they are enabled.

      The setting isn't in global settings or the game profile settings anymore. The entire gaming tab in "Radeon additional settings" has disappeared.

       

      I have uninstalledGlobal Settings.JPGGame Profile Example.JPGRadeon Additional Settings screen.JPGGPUz Snap.JPG and reinstalled with DDU and AMD uninstallers many times. I have tried rolling back to drivers from the past (the last that works is the one from april). There have been others having this issue as well.

       

      Need some help.