1 Reply Latest reply on Sep 6, 2016 5:03 PM by kingfish

    AMD Install stuck on 2% (Plus general driver issues that would make this name too long)

    ajgoddu

      Hello, I have recently had to reinstall windows (due to an issue upgrading to windows 10 that resulted in making my main drive un-bootable)

      After installing things such as MOBO drivers, and Network Adapter Drivers, I tried to install the drivers for my XFX RX 480, 8gb from the disk. The install program closed with an error saying: Detection Driver Error. Contact AMD for assistance. during the Analyzing System phase. Shortly after another error message appeared saying that the file on the disk: atdcm64a.sys was unsigned and that Windows stopped the process from installing. (Detailed here on this forum where I looked for a solution to that issue: Detection driver error. Contact AMD for assistance [Solved] - Graphics Cards - Graphics Cards )

       

      I went and viewed the files on the disk and verified that the file was in fact signed. As a result, I decided to go onto AMD's website and try their auto-detection tool to save me a little bit of work. The tool ran, analyzed my system and recommended the proper drivers, and downloaded them. (at least it said it did, I never found them anywhere) but after that it just sat there. I briefly looked into the issue but smelling another little bug I did not want to deal with I just went onto AMD's website and downloaded the latest drivers (16.8.3 at the time of this post) and started to install it. It analyzed the system and ran, but on the installation progress bar, it stuck at 2% for about 3 hours. At that point I was pretty sure that something was up so I tried restarting it, and waited another hour. Same thing. I browsed forums (including this one heavily) and tried many things such as using different versions such as the 16.7 series of drivers, disabled windows defender, retried after using AMD's uninstall tool to remove everything and rebooting, tried installing Microsoft's .NET framework directly from them (that also did not work, which is where I think it is getting hung), disconnecting from the internet, disabled Antivirus, and even tried installing versions that didn't have the .NET framework on there. I am pretty much at the end of my personal ability here so would anybody here have any suggestions about this issue?

       

      (sorry it is so long, wanted to include as much information as possible)

       

      System Specs:

      OS - Windows 7, 64 bit, on SP1 due to clean install from disk, unactivated (I plan to upgrade to windows 10)

      CPU: AMD FX 8370 Black Edition, 8-core

      RAM 16gb of Corsair Vengeance, DDR3 1600

      Motherboard: Asus M5A99X R2.0 EVO

      Driver: Currently attempting install of 16.7.2 for multiple hours

      PSU: Some Thermaltake Silver, 800W

      GPU: XFX RX 480, 256bit, 8gb of GDDR5

       

      Again sorry for the length, I hate calling AMD but if nothing is reached I will probably have to in the next few days.