AnsweredAssumed Answered

I NEED THE 16.20.1025 DRIVER VERSION FOR MY AMD RAEDON R6

Question asked by ejcudo on Sep 5, 2016
Latest reply on Sep 5, 2016 by amdpete

I need it to play the Battlefield 1 open beta, when I run the game it displays a window that says I need the 16.20.1025 driver version. How can I get it?

Outcomes