AnsweredAssumed Answered

Rx 480 no signal

Question asked by hakooon on Sep 4, 2016
Latest reply on Sep 6, 2016 by hakooon

Hi guys. I finally registered on this site after a whole day googling my problems without luck. So here's my story:

 

I bought a Sapphire Rx 480 Nitro 4gb as an upgrade for my system to replace my GTX 570. I deleted and cleaned all my other drivers before I installed the card.

 

At first it worked great for about 20 minutes, then my screen went black and the monitor was getting no signal. Everything inside my pc seemed to still be running, including the RX 480.

 

I had to power off and on two times before it worked again. This time it worked for about 10 minutes, and then the same thing happened. I read some forums online that said I had to roll back to some older drivers. So I cleaned all drivers again and did a fresh install of older drivers (recommended by an amd employee). This time my pc worked for maybe 45-60 minutes, and I thought all was well. Then I bumped my case a little by accident and I got the same problem yet again! My first thought was that the gpu was loose in its slot, but it wasn't.

 

After trying to restart my pc about 20 times without getting a signal, I gave up and plugged in my old GTX 570. I got a signal right away, but apparantly my pc couldn't boot from my SSD anymore, and my SSD's name shows in bios with some funny signs around it (like a smiley), and only shows a 1gb capacity. I googled this problem as well, and apparantly my SSD is bricked!

 

My first thoughts then was that maybe it was the SSD acting up all along, and making me lose signal to the monitor? My SSD was loose inside the case because I didn't have a bracket when i installed it (stupid, I know). But then why is my RX480 not even showing BIOS when my GTX570 works perfectly? When I plug in my RX480 now the fans doesn't spin at all, but the Sapphire LED is glowing, and I'm 100% sure that it is seated and connected properly.

 

So naturally I started googling again, and it appears the RX480 needs a motherboard with uEFI bios. I'm pretty sure I have that though on my Sabertooth p67 gen 3.

 

In short I guess my question is: Why isn't my new RX480 giving any signal to my monitor (and fans not spinning at all), even in BIOS, when my GTX570 works flawlessly?

 

I'm desperately needing help with this, and I will try whatever you suggest! What should've been a happy upgrade day turned into a nightmare!

 

EDIT: I cleared the CMOS (at least I think I did it correctly, button next to the RAM) and rearranged the cables coming out of my PSU so that the cable that runs to the GPU is the only one connected to the "+12V4DC" section on the PSU. The card now boots, with the fans running, and there is signal to my screen in BIOS (or uEFI or whatever)! I'm going to buy a new SSD tomorrow to try a fresh install of Windows 10, and hopefully everything will be alright then.

 

I am however terrified that this problem will repeat itself, so I'm still curious about what you guys think caused this problem? Do you think it will all be OK with a fresh install of Windows? Does my motherboard even support this card (do I have uEFI?) Thanks!

 

 

My specs:

MB: Asus Sabertooth P67 gen 3

CPU: Intel Core i7 2600k

RAM: 8gb (2x4gb) Corsair

PSU: Mist 1000W modular

Outcomes