2 Replies Latest reply on Sep 27, 2016 1:45 AM by helloitsmeu

    Rx 480 stopped working after latest driver installed

    usert

      Hi!

      A week ago I decided to update the graphics driver for my RX480 8GB I've been using for almost a month(bought it day 1), it used to work perfectly straight out of the box with the latest driver from AMD's website.

      I got the notice to update my drivers when I booted into windows 10, after a few seconds on installing/updating the screen went black for a few seconds, then it displayed "going to sleep mode" for a few seconds before turning black again, this goes on and on in a loop. After 15 minutes of this I remoted into the computer and the AMD window says that the driver installed succesfully, so I hit the "restart now" button, the computer restarts and after the windows 10 logo it goes straight back into black screen for a few seconds, then to "going to sleep mode" and back again in a loop.

      I once again remote into the computer and uninstalled the AMD driver, rebooted the computer and I get into windows 10 just fine (image resolution is horrible and It can't take 3 screens) at this point the video card is set to "Microsoft basic display device" in device manager. I've tried the AMD driver uninstaller and downloaded the latest driver from the website without luck. Same issue with the screens going in and out of sleep mode. I just tried updating my motherboard driver aswell as reinstalling windows 10 to the version before the anniversary update without luck. Same as before, the graphics card works "fine" without drivers but as soon as I try to install any the screens will stop to work.

      Was I just really unlucky and the card broke just as I tried to update, as I said before it was fine for a few weeks before I tried to update.

       

       

      OS Windows 10 (Tried both anniversary update aswell as the build before)

      Motherboard ASUS Z97-P Running the latest BIOS from the website 2907

      Graphics card RX480 Running latest AMD driver (Tried the older I can find aswell)

      3 Screens all connected with displayport (Setup has worked earlier)