2 Replies Latest reply on Sep 1, 2016 9:13 AM by jie386

    RX-480 Crossfire (primary GPU not detected)

    jie386

      Hi,

       

      I have recently built a pc with dual RX-480's. The GPU's have performed very well together and I placed EK waterblocks on them which saw them further work well under lower temps.

       

      Recently today I removed the GPU's out of my case to do some work (replaced cables and installed lighting) to which I found that when I booted my PC up again, my primary GPU was not working.

       

      I swaped out the 6 pin for the secondary 6 pin which did not work either. My secondary card is currently driving my system and when I logged into Windows (7 Ultimate / 64) I found that device manager and the AMD Settings program did not detect my primary GPU.

       

      The GPU has not been damaged in any way. It has not sustained physical or thermal damage.

       

      Solutions I have tried so far:

      1. No changes were made to the BIOS, to be safe I cleared the CMOS - didn't work.

      2. I ran DDU to remove the drivers I was using and did a fresh install to the latest drivers - didn't work.

      3. A bit of a long shot... I dusted out my pc and PCI-E slots - didn't work.

      4. I tried relocating the 6 pin connector on my power supply to another slot in case it was a rail issue (Corsair RM1000i) - didn't work.

       

      Does anybody have any solutions that I can try?

       

      If this helps in any way, this is my build log: [Build Log] - MasterCase Pro 5 - Ragnarok