1 Reply Latest reply on Sep 1, 2016 10:27 AM by ray_m

    Major problem with my HD 7870. Brown screen while gaming and now black screen after windows loading screen.

    cerberus_v

      Hello to the community. My problem started a few days ago. As i ve mentioned on the title, i own a Saphire Radeon HD 7870 (GHz Edition) and while i was playing a video game, the screen turned light brown and the system froze. I had to press the reset button. After resetting,  the computer booted, windows started loading and after it finished, i got stuck with a black screen and nothing else happened. The behavior was the same each time i tried to start the computer again. After a few tries, the windows boot options appeared since windows didnt start so i decided to select the "reset this computer".. The proceedure started normally but after a few minutes, the screen turned black again and i got stuck. I pressed the reset button and when it did, the screen had some flickering pink/green squares and the image was distorted and teared (was showing me an error message but i could barely read what it was saying with the degree of distortion). Since resetting failed, i decided to install windows from the start. I activated my onboard graphics card and plugged my monitor there, just to be sure that it will work. I didnt disconnect my GPU though. Windows installation happened with no problems and when it was starting, it started downloading and installing drivers for both my onboard graphics and my GPU. The intel onboard graphics were installed properly but when it tried to install the AMD GPU drivers, i was getting BSODs each time. I disconnected my AMD GPU and now the computer works fine with just the onboard graphics. The next day i took my card to a friend to test it on his computer as well. His computer booted windows normally but after 1-2 minutes on desktop his screen turned black as well and the system was unresponsive. It seems that the card is working only with the generic windows drivers and when the computer tries to install the proper AMD drivers, it shows black screen and doesnt work.In both computers. Has anyone had similar issues? Is my 7870 damaged or is it somehow a driver issue? I never overclocked neither my CPU nor the GPU and i had the latest drivers installed.

      My system is:

      Windows 10 Pro

      Intel core i5 4690

      16 GB RAM (Kingston Hyper X savvage)

      M/B: Gigabyte Z97-HD3

      PSU: Corsair TX-850M (850 Watt)