9 Replies Latest reply on Sep 6, 2016 3:08 PM by fulvix

    GPU LOAD 100% solved?

    dexxyx

      So i mentioned that my gpu load is 100% started to read forums here and nothing helped. Then i played with radeon settings maybe and something really goes wrong my screen turned to black and then windowbox "radeon host settings was closed or how windows shows it i dont remember" and now i don't have problems with load anymore. GPU-Z shows gpu load at 0%. So maybe if someone have this problem try to kill process in task manager what related with "radeon host settings" i also tried to play games and it works really better gpu load not at 100% and power consumption is great now.

        • Re: GPU LOAD 100% solved?
          jasonc44

          I  have the same issue too.  Something is wrong with the driver and amd ignores to see it

          • Re: GPU LOAD 100% solved?
            middy

            i have the issue as well. it only happens at bootup of my computer into windows or from resuming from sleep. for the time being i disabled sleep. i'm in a particular boat as I have crossfire and only my primary card gets the load:

            here is a pic of my gpuz's:

            http://i.imgur.com/hZRMmnv.png

            bootfullload480.png

             

            like you noticed, i noticed if I simply go into wattman, wattman itself starts to lag like crazy (five second delay for anything) then my screens flashes "black" as if it was about to have a TDR, but then recovers without causing a TDR, and wattman crashes. the wattman screen goes completely transparent. after wattman crashes the load my GPU returns to zero and its clock speeds drop down. memory during the 100% usage switches back and forth between 300mhz and 2000mhz.

             

            first the colored screens at idle (seems like the new drivers fixed it so far) and now the 100% load. crazy.

              • Re: GPU LOAD 100% solved?
                greytoad

                I've had this problem with the 16.8.2 driver and the 16.8.1 driver on my rx480 reference card.  I haven't tried the 16.8.3 driver.  For me, I have to do a cold boot to get it to stop.   I'm under water so I didn't notice at first.  GPU temp doesn't really move for me, but VRM temps go up as it never throttles down to idle.   Warm booting leads to the problem persisting.  Only cold booting works to resolve the problem for me.   I associate the %100 gpu usage with a couple of lockups I've gotten but I have no way to know for sure if they're related. 

                 

                It doesn't seem to be related to whether or not I've changed wattman settings.   However, I've noticed since the 16.8.1 driver that my memory setting can get stuck if I alter it while HWINFO64 is open and my gpu is at idle.   Wattman shows the correct setting but my performance goes to heck.   Cold boot sometimes resolves that too. Uninstalling the drivers, running DDU in SafeMode and reinstalling the drivers is sometimes necessary.   Reset in wattman does not resolve the issue.  Not sure if the two problems are related.   Both seem intermittent.

                 

                I'm not currently having the issue, but when it comes back I will try ending task on Radeon Settings and restarting it.   I'll try the same for the issue I'm calling the memory clock stuck issue.   I've never had either fixed without at least a cold boot.  It'll be interesting to see if it works.   I'll report back if I have the problem again and if that works. 

              • Re: GPU LOAD 100% solved?
                the_mard

                Heyyo, hmm the thing with 100% GPU load is how AMD handles power saving differently than Nvidia. Nvidia's adaptive performance ups the clock speeds before reaching 100% usage, where-as AMD keeps the usage at 100% and ups the clock frequencies as it needs to in order to either get VSYNC lock (or attempt to). Disabling Power efficiency mode in the Crimson software does make it up the clock speeds earlier which can help maintain VSYNC lock a little easier.

                 

                Another thing I noticed? middy, you mentioned Crossfire and stability issues... have you tried disabling ultra low power state? I'm unfamiliar with the Crimson software and CF so you'll have to hunt for that setting and disable it or use MSI Afterburner which has it in the general settings. UPLS essentially disables any GPU but the primary when it's not needed to save power, but sometimes can cause stability issues... maybe that could be your solution? Try that out. If you want to try MSI Afterburner? Get the latest beta as it also supports Polaris overclocking and RTSS meow supports DirectX 12 overlay in game.

                 

                Check it out:

                http://i.imgur.com/rI0zBy8.png

                 

                You can find the latest MSI Afterburner beta on the official MSI website and Guru3D

                  • Re: GPU LOAD 100% solved?
                    greytoad

                    When I've had the issue it stayed at max clock on the card.  I think Middy is only getting it on one of two cards, so it's more that the power saving is broke .   The issue occurs on the desktop doing nothing and the gpu isn't actually doing much other than staying at full clocks.  

                     

                    The "ultra low power state" in crimson is the Power Efficiency setting on the Global Settings page I believe.  It holds the card to idle clocks while on the desktop and makes it slower to ramp up clocks if it's had to throttle down for power limit issues. The default is off.  Is that the setting you're referring to?   I turned it on and while I don't know if it's related, I haven't yet had the issue again.   FYI.   I'm not running crossfire so I can't comment on whether or not the setting might cause stability issues with that.  

                    • Re: GPU LOAD 100% solved?
                      middy

                      ULPS is off. I always turn it off. i also don't have any crossfire stability issues. i just mentioned it to point out that when it happens, it only happens on the primary card, not the secondary. so far for me, it only happens occasionally when i startup or resume from sleep.

                       

                      this seems to be common. another user from this thread:

                      Started getting black screen (and White Screen) RX480 Crimson WHL 16.7.3

                      fxv3000 gets it too when he resumes from sleep.

                    • Re: GPU LOAD 100% solved?
                      fulvix

                      I have also had the same problem with a sapphire rx 460. I solved by disabling the quick launch windows 10.

                       

                      Before starting the PC GPU was 100% and only doing a reboot returning to 0%. Now it seems to work. The problem recurs if I put the PC in suspension and after back to 100%. But I never use the suspension.

                       

                      If I have other problems I notice but for now I'm happy to have solved.

                       

                      Sorry for the English google but they are Italian.