4 Replies Latest reply on Aug 30, 2016 5:25 PM by a.i.

    Linux kernel driver

    inventor71

      I am installing the latest driver for my video card and its been an adventure. I am using Kubuntu 16.06. I know its not supported but any way. I have successfully got X working with the new driver except for one part. I can't find the kernel driver. I have the X driver and modules installed correctly. The kernel is looking for the frglx.ko file and I can't find it anywhere on my system. Any Ideas?

        • Re: Linux kernel driver
          inventor71

          Video Card AMD Radeon HD 8670 / R7 250/350

          Software used = radeon-crimson-15.12-15.302-151217a-297685e
          Computer = Dell Optiplex 5040 Desktop

          OS = Ubuntu 16.06

          Memory = 8 Gb

           

          Cant think of any more relevant information to my problem.

          • Re: Linux kernel driver
            inventor71

            More Information. Tried compiling the kernel module and got this error.

             

            AMD kernel module generator version 2.1
            doing Makefile based build for kernel 2.6.x and higher
            rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
            make -C /lib/modules/4.4.0-34-generic/build SUBDIRS=/usr/src/fglrx-core-15.302/2.6.x modules
            make[1]: Entering directory '/usr/src/linux-headers-4.4.0-34-generic'
              CC [M]  /usr/src/fglrx-core-15.302/2.6.x/firegl_public.o
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c: In function ‘firegl_major_proc_read’:
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c:634:9: error: void value not ignored as it ought to be
                 len = seq_printf(m, "%d\n", major);
                     ^
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c: In function ‘KCL_fpu_save_init’:
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c:6458:49: error: ‘XSTATE_FP’ undeclared (first use in this function)
                   if (!(fpu->state.xsave.header.xfeatures & XSTATE_FP))
                                                             ^
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c:6458:49: note: each undeclared identifier is reported only once for each function it appears in
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c: At top level:
            /usr/src/fglrx-core-15.302/2.6.x/firegl_public.c:6448:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]
            static int KCL_fpu_save_init(struct task_struct *tsk)
                        ^
            scripts/Makefile.build:258: recipe for target '/usr/src/fglrx-core-15.302/2.6.x/firegl_public.o' failed
            make[2]: *** [/usr/src/fglrx-core-15.302/2.6.x/firegl_public.o] Error 1
            Makefile:1403: recipe for target '_module_/usr/src/fglrx-core-15.302/2.6.x' failed
            make[1]: *** [_module_/usr/src/fglrx-core-15.302/2.6.x] Error 2
            make[1]: Leaving directory '/usr/src/linux-headers-4.4.0-34-generic'
            Makefile:88: recipe for target 'kmod_build' failed
            make: *** [kmod_build] Error 2
            build failed with return value 2

            • Re: Linux kernel driver
              a.i.

              This looks like same problem which has been solved with a patch by nenad for catalyst driver.

              Try heading over here:

              https://bluehatrecord.wordpress.com/2016/03/25/installing-the-proprietary-amd-crimson-driver-on-fedora-23-with-linux-kernel-4-4-6-300/

              there are links to patches and plenty of discussion if you scroll down. There are also previous posts on same site regarding previous kernels.

              The one must is that you will have to downgrade your xorg to 1.17 or earlier.

              The good news is that crimson driver is working with xorg 1.16 and 1.17 on kernel 4.6.7 on Fedora 23 and Fedora 24. So if you can patch the driver you may well be able to get some sucess on Ubuntu.