0 Replies Latest reply on Aug 26, 2016 9:07 AM by rooneywatson

    Radeon Software Crimson Edition 16.8.2 Installer Crashing

    rooneywatson

      Around a week ago I downloaded this latest version for my Amd driver as I have never updated my drivers since getting my laptop. About 2 days later I turned my laptop on to find that, when trying to launch the AmdSettings application, A message told me that I was missing my drivers. Once I got this is uninstalled my drivers with the Amd Cleanup application and re-downloaded this driver. It worked for another few day and did the same thing again. I began searching the internet trying to find a fix, I then came across a forum saying that Windows 10 was updating and changing the drivers, I use and application to stop windows from doing this update. After restarting my laptop again I found that the problem was on going so I removed the driver again, when trying to re-install it again, The installer would keep crashing (As seen above). After attempting this many times I downloaded an earlier version of Crimson (16.7) Which seemed to work but when it installed, It did not contain the Radeon Additional settings. I could not fix this problem so I once again uninstalled and retried. When trying to launch AMDSettings I got an error stating that Qt5core.dll, Qt5check and various other Qt5----.dll files were missing so then Amdsettings could not launch, after going online and searching for a fix, I downloaded those missing files and placed them back into the System32 folder. After doing this a different error message came up telling me that "the application was unable to start correctly (0xc00007b)". After trying for a long time I was unable to fix this problem. So in the AMD Gaming evolved application I saw that there was an update panel, after clicking on this, once again trying to install Crimson 16.8.2 I came across the "Stopped working" message as seen above.

       

      I have spent about 5-6 hours on finding a fix for this over the past few nights and have been unsuccessful. Why is this still happening and how can I fix this problem?

      Thanks!

       

      If needed here is the graphics card I currently use:

      AMD Radeon HD 8600M Series

       

      I also use Windows 10