AnsweredAssumed Answered

rx 470 black screen halfway through driver installation

Question asked by bellcross on Aug 22, 2016
Latest reply on Aug 24, 2016 by alpere

  Hello, bought sapphire nitro + rx 470 4gb  10 days ago, still haven't been able to make it work. I waited a week for it to be inspected by the merchant that sold it to me and I am getting it back tomorrow. On their test bench with a pentium processor, h170 mb and win 10 install - the card worked.

My system is

i5-6500

Msi h110 pro-d

ddr4 2133 8gb kingson

crucial bx200 ssd 240gb

sg 1tb baracuda

xfx 430w 80+ bronze

 

windows 10 pro

 

Before I sent the card back, I removed the drivers using ddu, installed them from the provided disk - the moment I boot up the system with the card and it turns off to adjust the resolution - it does not turn back on "no signal detected" as if I don't have the card connected to the monitor, I checked many times - it is connected. I tried doing the same only using the latest drivers - same story. My old  radeon 7770 woks just fine when I put it in. This is just infuriating.

 

The only difference I could see through a lot of reading and scratching my head the past few days is that my boot up is legacy, not UEFI. The merchant suggested I do a fresh install with UEFI boot.

I think I will ask for my money back if that does not work thou.

Any suggestions or some easy fix that I am missing ?

Outcomes