3 Replies Latest reply on Aug 22, 2016 8:50 AM by drumsann

    Sapphire Nitro Fury flickering in games and on desktop

    drumsann

      Hello,

       

      I've bought a Sapphire Nitro Fury to replace my HD7870 2 weeks ago and one week ago, it started to flicker. It is just one black flash, sometimes white.

      I've verified the cable and it's good, wattage is good too. I also reinstalled the drivers and installed one former driver to see if it was the newest one who was buggy but it didn't work.

       

      Specs :

      GPU : Sapphire Nitro Fury

      CPU : FX8150 3.6 GHz

      8 Go DDR3

      650W

       

      I don't know what to do right now, I think I'll just refund my card. What do you think please?

        • Re: Sapphire Nitro Fury flickering in games and on desktop
          dra6o0n

          I had a similar experience with my XFX RX 470 when I overclocked it a bit within the levels, and was trying to play World of Tanks at 120hz, then changed to 100hz once i notice those flickering.

           

          It still flickered and then the game crashed by refusing to render and shows your desktop, except the game overlay is still on top of your screen so you can't click on anything.

           

          I had to force close it using the keyboard and task manager since the mouse clicks are literally blocked off.

           

          Also, due to a bug or a issue that hasn't been solved for quite a long while now, I can't utilize 144hz on non-displayport connections such as DVI-D.

          My R7 370 does that easily as my monitor supports it.

           

          When I set it to 144hz, it flickers randomly whenever the mouse moves and then the system would crash or freeze. This is a known issue that hasn't been resolved since Crimson 16.7.2...

          • Re: Sapphire Nitro Fury flickering in games and on desktop
            weirwood79

            Right click your desk top.

            Go to Display Settings.

            Go to Advanced Display Settings.

            Click the Monitor Tab.

            Change refresh rate from 144, down to 120 (or anything between 60 and 120) which ever is closest to your monitors refresh rates.

             

            At the moment 144hrz is causing flickering in the display. It's driver related so setting for 120 or a bit less for now.

             

            I too discovered this when I installed my new RX470 with latest drivers, it was only dumb luck that I thought to lower my resolution and then back to 1080p to discover my refresh rate had went to 60 by default. When I put it back to 144, it started flickering again. Putting it @ 120 solved the issue.

             

            I thought it was a bad card before figuring that out.