0 Replies Latest reply on Aug 18, 2016 8:05 AM by viterzgir

    Display driver doesn't recognize my videocard

    viterzgir

      Hello!

      I have a problem with black screen (without mouse cursor) while desktop loading.

      Video card is Sapphire R9 270X Vapor-X.

      OS : Windows 10 Enterprise.

      Drivers on which corrupt occurred: 16.6.2

      Processor: AMD A8-6500

      8GB RAM

       

      It started a months ago after I updated my video drivers to 16.6.2 (I guess it's right number. It was 16.6.x definitely). My computer worked OK sometime after that but then while I've been playing a game, artifacts appeared on my screen and computer restarted. BIOS and Windows load was good but when it reached desktop - black screen appeared and computer restarted.

      I decided to delete all drivers through Safe Mode but it didn't help. Computer loaded to desktop (even desktop was shown) but after 1 minute of using it restarted again. Black screen appeared again.

      I re-installed Windows - it didn't help. Problem is the same.

      I tried to installed Windows 10 Enterprise, Windows 10 Pro, Windows 8.1. Nothing helped. ISO images I downloaded from Microsoft site.

      Then I thought that the problem with my Power Supply so I bought a new one - it didn't help. I bought a new molex-6pin cabel - it didn't help.

      I gave my video card to service so they'd test it - all tests are OK (2d and 3d).

      I have an old video card R7 200 series and it works perfectly on my system.

      I tried to use amd clean up utility - it didn't help.

      Also, I brought my whole system case to service to check it - and it worked well with their hard drive. So I though that the problem is with latest Windows updates and installed Win8.1 but as you read above - it didn't help.

       

      And yesterday, when I turned off auto updates and auto install drivers in Windows Group Politics it started to work. I tried to download and install different video drivers (like 16.3.2, 16.7.3, 16.8.2) - but every time it failed to install Display Drivers. It seems that my computer doesn't recognize my videocard. But in Device Manager window it shows me as R9 200 series adapter. What can it be? What should I do?

      I'm desperate.

      Please, don't tell me to delete drivers from Device Manager\Safe Mode or reinstall windows - it doesn't help. Don't tell me clean my computer from dust - already did it. Don't tell me to do a system restore - I did it too. It seems that I did all I could and it just doesn't work.

       

      Sorry for my bad engRish :/