3 Replies Latest reply on Aug 16, 2016 4:13 PM by amdpete

    R9 fury low FPS (only in "Skyforge" (game)) -2015 Playable

    darigaaz

      With this graphic I'm over the minimum requirements, I have tried almost all combinations of the configuration of Crimsom and game aswell.

      Game does not goes further than 23.7FPS

        • Re: R9 fury low FPS (only in "Skyforge" (game)) -2015 Playable
          amdpete

          I am not seeing that in the game except at 4K which is kind of what I would expect.  I get 70 - 80fps at 1080p Max ingame details except vsync.

           

          Tested on starting city and first mission map.

           

          Tested on Win 10 X64

          1 of 1 people found this helpful
            • Re: R9 fury low FPS (only in "Skyforge" (game)) -2015 Playable
              darigaaz

              First of all thanks for answering, I really appreciate your opinion because now i know it can be at least solved.

               

              I do not have the option of increasing the graphics over than "Maximum", (it says my sistem is 8.2/7 and 8.1/7 for Max), I 've tried a fresh installation of the game, even set as "High" and still the fps around 20.

               

              I'd really appreciate if you could send me a screen of your crimsom config and game graphic configuration, looks i have something activated/deactivated and it shouldnt.

                • Re: R9 fury low FPS (only in "Skyforge" (game)) -2015 Playable
                  amdpete

                  My Radeon Settings are all set to default so no real reason to post those.  I don't have the Fury card in the system at the moment but I can post a pic of the game settings I was using.  I am currently using my RX 480.

                   

                  Skyforge_2016_08_16_22_04_30_965.jpg

                  If you think you have something set wrong in the Radeon Settings you can always reset the game profiles to default and reset all the driver settings to default with the preferences section 'restore factory defaults'

                   

                  Just as a reference since I happen to have it installed I am getting 30fps at 4K with the RX 480 with the above settings.

                  1 of 1 people found this helpful