18 Replies Latest reply on Aug 19, 2016 12:12 PM by buglepong

    r9 290 gigabyte windforce Thread_stuck_in_device_driver

    spartankilla109

      HI all,

                   So ever since AMD went into updates 16 and above my card gets the BSOD Thread stuck in device driver and restarts my computer while either browsing the web (all web browsers) and while playing some games(at random times), I have had this problem since around march and i have tried updating drivers again, doing a complete driver wipe, I tried doing a full install and also a minimal install but with no luck, still getting error, the only work around i have found was to go back and re download an old driver that works which is (amd-catalyst-15.7.1-win10-64bit) one of the problems with running such an old driver is that some newer games are not optimized or do not work any help would be greatly appreciated, i'll give some pc specs and other details below.

      When it crashes i am playing games or web browsing, no game recorder is on and raptr is uninstalled.

      Motherboard: asus z97-a

      OS: Win 10 64bit

      CPU: i7 4790k

      Ram: 8gb

      GPU: r9 290 gigabyte windforce

       

      If i have missed anything or you would like more info please ask..