3 Replies Latest reply on Jan 9, 2018 8:38 AM by daigu

    "Rendering device has been lost" (Overwatch)

    nubcake

      Hello,

      i got Overwatch crashes for quite some time now, but i'm only typing it now, because i actually did a CLEAN "Windows 10 Anniversity Edition" install few days ago, so i'm pretty sure the issue is not on my end. I get crashes in Overwatch quite often (every 1-2 games), mostly it said "rendering device has been lost", now it just crashes and i have to hard reset the PC. Why i'm typing here is, because i already wrote to Blizzard support (sending them DxDiag and MSINfo32) and they told me that my Graphics Card is not installed correctly. So let's get to the graphics card not installed correctly.

       

      I installed fresh copy of windows 10 AE, Windows Update upgraded everything (installed some AMD Drivers too), then i ran the "update" in Crimson and i got some error, meaning i couldn't update there, so i downloaded the latest drivers (using "Crimson Edition 16.7.3 & 16.8.2 Hotfix" atm) and i'm still getting crashes. Right after i installed the "Crimson Edition 16.7.3" i got an notification saying "Default Radeon WattMan settings have been restored due to unexpected system failure", i obviously have no idea what that means, but i just went along with it, hoping everything will be fine, but it's not.

       

      Blizzard support told me (from what they could see from msinfo32) that either my HDMI cable is plugged into motherboard (which is not) or my graphics card is not installed properly, so i'm pretty sure there is a bug with the drivers installation, please tell me what info i need to provide to you, so you can fix it, i'm pretty sure there is nothing on my end, since i literraly tried everything and NOTHING helped, please don't tell me to reinstall drivers, cuz i already did (=

       

      I'll attach "DxDiag" and "MSInfo32".

       

      PS: Since i don't think it says in the files, my Motherboard is "Gigabyte GA-Z97X-Gaming 7 (rev. 1.0)".

       

      Greetings