3 Replies Latest reply on Jan 18, 2017 9:36 AM by alphagambit

    i have r7 370 4gb

    vestiges

      last month i had 120fps in world of warcraft after updating to 16.7.3 im getting 25 to 80 fps do i need to roll back my drivers and wait for next update

      https://www.dropbox.com/home/wow?preview=DxDiag.txt

        • Re: i have r7 370 4gb
          amdmatt

          If the new drivers are causing reduced performance on your system, yes.

          • Re: i have r7 370 4gb
            alphagambit

            Im having that same issue but a tad bit further on the list lol first of all lowered FPS in any game i am playing from Arma to minecraft to well every game available and I am set to recomended settings in every game it avails that option. my problem and im not sure if you may be having this as well is the fact that I am reciving huge frame drops for 5 seconds to 1 minute of time about every 30 minutes to an hour. Please let me know if you have this as well its been on the latest drivers. (Overheating issues arised as well.)

            • Re: i have r7 370 4gb
              alphagambit

              So i did find out that there were a few changes in the driver update that brought FPS back to me in wow but they are still not fully there so in this case to get those FPS where are you running and what graphical setting are you using(i.e. the Recommended settings or your own cocktail of settings)?

               

              I currently run at about 45-55FPS on setting 7 the recommended for my system but then again i am fully AMD as you are but I am running a stronger CPU (FX-8320 Black Edt.). I actually recieve my usual 90-120+FPS in azeroth even BC areas but when im in Legion or draenor different story since they are built around better and more enhanced graphics that are meant to be run with AA mainly CMAA. that could honestly be your entire problem.